FireflyElectronix Doorbell Integration

I picked up a doorbell sensor from fireflyelectronix. They have some very vague instructions on adding it to HA using MQTT…needless to say, I’m not having any luck.

Here are the instructions they included

What I’d ideally like to do is get it setup to send an iOS notification to both my phone and my wife’s phone. Seems completely possibly, I’m just a little new to this whole platform so I can’t quite figure it out.


I basically setup a sensor to grab the battery voltage, which changes on each press, and is nice to monitor to know when I need to change it.

Then fire an automation based on that sensor updating. Note the first condition prevents it from going off anytime you restart.

Let me know if you need anything else, also @fireflyelectronix is a member on here if I get stumpped.

Thank you,

I guess part of my misunderstanding is setting up the automation end of it within the HA GUI. I setup the trigger, but its the Action part that has me stumped. From the looks of it, you did the setup through a configuration file.


Hi @james211,

For the automation to send to two phones, you can add multiple actions. Just duplicate the action from the first one and change service dropdown to the other phone. Here’s a screenshot from the GUI.

I tried that but I get an error message…also I’m not using a camera setup so I’m not sure why I’d need that part of the script.

Ok. Since you don’t have a camera setup that may be why you are getting the error. If you want to setup a basic notification, copy this in the service data section.

  "title": "Doorbell Notification",
  "message": "Doorbell Pressed"

Okay I’ll give that a shot.

I have a nest camera, but I haven’t figured out how to use it to grab a photo yet.


So I’ve tested that my iOS notifications are working, and I’ve double checked the settings with my doorbell sensor…see screen shots, but when the doorbell rings I’m not getting any notifications. If I use the IFTTT it works.

I also went into logbook, selected Doorbell, made sure it was on, and if I click “Trigger” I get the notification.

***Update: So if I remove all of the MQTT info, and only use the IFTTT key, the sensor shows up on my wifi network and I can ping it. If I remove the IFTTT key, and put the MQTT login info in, the unit does not show up on my network nor can I ping it. I have verified that I can login with the MQTT IP address and credentials with MQTTfx. Any idea why it doesn’t show up on network when the MQTT is used?

Hi @james211,

What is the port that you are using to connect to your Home Assistant MQTT? It looked like you had port 8123 set. Tyipically MQTT operates on port 1883. Did you change the MQTT port settings to 8123? If you didn’t manually change the default MQTT port, then try using port 1883.

Prior to reading through the documenation I had it set at 8123, but I later changed it to 1883. I can login with the credentials using MQTTfx. The part that baffles me is it doesn’t show up on my network if I’m using the MQTT setup, only if I’m using the IFTTT setup.

I also sent an email directly to you guys.

is this going to be a case of chasing you guys down for an answer? I’ve emailed you and conversed with you on here.

I’ve walked through all the steps to set up the MQTT with someone else, in the end the problem is the unit is not showing online when MQTT is used.

Hi @james211,

We just sent you an email for some things to troubleshoot. We are commited to getting this working for you. The sensor is in sleep mode most of the time so you shouldn’t be able to see it connected to your router. Once the doorbell is pressed, it wakes up sends the message and then goes back to sleep after 10 seconds.

Thank you for being such a great help with resolving this issue.