Firmware updates to Aeotec Z-WAVE devices

I’m looking into getting some Aeotec Nano Dimmers for around the house.

My question is: how do you update the firmware if/when they release a patch? Can you update the firmware while the USB stick is still in Hassbian?

My Aeotec Gen5 USB stick is currently sitting on my Hassbian, and the only way I’ve updated the firmware in the past (for the Aeotec Gen5 Door Sensors) was to plug the Aeotec USB stick into my Windows PC, pair the device, update the firmware, hit the action button, remove the device, then pair all the devices again on Hassbian.

I’m not going to pull a bunch of dimmers out of the wall to repeat that process…

Any advice would be greatly appreciated!


also would love to know this.

I was curious too, and I it appears there is good news and bad news.

I found the firmware update instructions for the multisensor.

And it says it does do over the air updates, but appears to require windows.

I found the page for their switch, and it says the same thing.

Sad to hear that. I purchased two Aeotec devices today, the ZW100 multi-sensor and ZW112 door/window sensor. I have their zw090 z-wave USB stick attached to my RPi3 running Hassio since a couple of months, and Z-Wave works.

Now, the zw100 keeps sending burglar alarms every 2.5 seconds, and from what I gather from other sources there exists a firmware upgrade that will fix that.

So for Aeotec, I need to delete the devices from the zwave network, move the USB stick to a windows machine, move and reset the devices to upgrade, and then re-install the devices, reconfigure groups, automations, renaming devices etc etc.

Is there any support in the zwave standards for OTA / firmware upgrades? Any standalone tool that can be run?

According to the instructions you don’t need to remove the Switches if they are already connected to a Z-Stick.

If your Smart Switch 6 is already part of a Z-Wave network, please remove it from that network. Your Smart Switch 6 manual touches on this and your Z-Wave gateway's / hub's user manual will provide more specific information. **(skip to step 3 if it is part of a Z-Stick already)**

Am I reading this wrong, meaning, I can just move the Stick to PC, do the Update, move it back to HA and done?

1 Like

They make out the process is all very easy with OTA updates, when in fact it is a pain. Even worse when you don’t have a windows machine. Run a VM setup with windows. I use a non production z-wave stick to do this, unpair your devices from your production environment, re-pair with the spare and do the upgrade.

It seems like my fears were unwarranted; In my case it was the multisensor 6 update that I needed.

I moved the Aeon stick to a Windows machine, downloaded the upgrade tool and hit Start on the Firmware update. Simple as that.


No need to unpair devices and repair correct?

Apparently it’s not that hard to update FW on Multisensors, but it seems that OpenZwave (and therefore also Home Assistant) DONT support Multisensors with FW newer than 1.08. Aeotec changed few things, and for now OZW doesnt support different configs for same device but different firmware versions, so the changes cannot be implemented in OZW. This is widely discussed on OZW github,

I’m unable to find the github you are referring to. Mind linking it?
I have the Aeotec MultiSensor 6 (ZW100) and wanted to update the firmware so that I can set Node config option 201: Temperature Calibration
However, if you say this is not going to work, then I obviously do not want to go ahead and do that.

I believe it’s somewhere here


I’d like to bump this question. I’ve got a number of Aeotec MultiSensor 6 devices. I’d like to get them upgraded, they have 1.12 now. Usintg the new Z-Wave integration, I get … “mixed-results” with adding and deleting them from the Z-Wave network.

I see the newest firmware is 1.15, and would like to flash my devices before they start shipping the newer multisensor 7 devices, so I can compare the two.

I’d need to buy a new dongle to OTA upgrade as I wouldn’t want to goof up my network on Hassio on RPi4.

So the real question: Has anyone heard of support for upgrading via the new Z-Wave JS integration? Or will I always need to upgrade them offline?



Interested in this as well, can’t find the actual firmware in the RAR from the download, just a bunch of tools, so assuming it needs to grab the FW on the fly?

according to this it has to come, but when? It stays on the roadmap forever… :wink:

Update Z-Wave devices directly from Home Assistant

However, I only Receive “Bad Request” when trying to upgrade my Aeotec MultiSensor 7 to 1.3.7 (EU) - Update MultiSensor 7 V1.6.7 : Aeotec Help Desk

Anyone have any success?

I am trying to upgrade my Aeotec Multisensor 6 to 1.15 (from 1.12). I’ve tried like 10 times. I keeps failing at various points in the upload process.

Update: It finally worked! I used the “.exe” file from the “.rar” file Aeotec provides.

1 Like

Hi jmwhite5, glad to hear your FW upgrade eventually worked out.

Since you mentioned in your first post that you attempted several times uploading the FW v1.15 by using the HASS UI which kept on failing, and in the next post you “used the .exe from the .rar” with success, I assumed that you reverted to the procedure where you remove device / windows pc with Z-Stick / run the FW .exe from aeotec / re-add the device.

I had issues with one of my AEOTEC ZW100 sensors which was on v1.14 while the others are on 1.15. Hoped to fix the issues (problems with lux values AND the device configuration page is empty) by updating the FW to v1.15, but the .rar file provided by AETOC does only seem to have a windows program, I wouldn’t know which file to upload through the HASS UI, all the files look like windows software and dll’s to me.

On the AEOTEC site I stumbled on a guide to update the ZW100 OTA through the homeseer UI, and there they do provide a download for the actual firmware file. Downloaded that file (MultiSensor 6_EU_v_1.15.hec) and updated the firmware right from the HASS UI. This did the trick for me and updated the sensor to v1.15 without any problems (did need a re-interview) and meanwhile fixing the lux issue and the ‘empty configuration’ page issue.

It’s been a while and my recollection is fuzzy. But I think I was trying to upload the .rar file. And then decided to try the .exe (extracted from the .rar file). I vaguely remember trying the upload the .hec file (from the Homeseer instructions) and not having any success. Glad it worked out for you!

When you download the firmware update from Aeotec, it’s a gz file. Uncompress it and you end up with a directory that has a subdirectory. Within the subdir, there are a number of files including a Windows executable that you have to rename in order to get it to run (the default extension is .ex_ and you have to change it to .exe). THAT is the firmware file, and you don’t need Windows to use it. You can choose that file directly from the Zwave JS interface to upload when you are choosing a device to do OTA update to.

I’ve had mixed results with the process overall where two Smart Switch 6 devices updated fine and reasonably quickly. I added two more to the network and the third one “finally” updated after almost a half hour process. The fourth one just hangs at low percentages every time, though, no matter what I try.