First automation with Tado

Hey all,

Im trying to do what i thought would be a simple automation. Tado heating is all added and working correctly.

What i’m trying to do is activate a smart plug if the temperature dips below a set level and deactivate when it hits another level (deactivate has a separate automation for now). Basically i’ve got a dumb electric radiator which I want to turn on and off when the tado thermostat reads a temperature. Ive attached my automation

Be good to understand what i’m doing wrong as nothing seems to happen

Smart plug is HS110 Kasa plug and works fine, i can control via home assistant perfectly


You could try and use a numeric state trigger instead of the device trigger.

Also, when you execute the automation manually, does the device turn on?

If you want to have both automations in one

- alias: "Tado temp then smart plug"
  - platform: state
    entity_id: climate.your_tado_device_here
  - condition: time
    after: "08:30"
    before: "18:00"
  - service_template: >
      {% if state_attr('climate.your_tado_device_here', 'current_temperature')|float >= DEGREES_TO_TURN_OFF_SWITCH %}
      {% elif state_attr('climate.your_tado_device_here', 'current_temperature')|float <= 21 %}
      {% endif %}
    entity_id: switch.your_swich_here

i’ll have a look using a numeric state

Yes, if i click “run actions” the radiator turn off and on correctly

What’s the friendly name of your Tado thermostat? is it “Temperature” as it shows in your picture? sounds strange. Did you type “Temperature” manually?

You must find your device in the Device drop down menu, like this:

so i “think” that the thermostat has physical entry in the home assistant (power, connected etc), then there is a Zone with the actual temperature. Ive attached the 2 entries

noticed you’ve used “measured temperature changed” rather than “temperature temperature change”. Do you know the difference?

You actually want to base your automation on the heating percentage.
When that goes over 0% turn on your plug.
That way it will automatically take into account, home away status, weather data, time, etc

Just do this. Put the entity_id of your tado thermosthat instead of mine. I believe it’s climate.temperature

Sure, if you want to turn a $100 smart thermostat into a $2 temperature sensor

1 Like

it’s 200$ acually. Weare turning a 200$ smart thermostat into a 2$ temperature sensor. Cool, isn’t it?

That’s why my suggestion makes use of the actual smart features.

Don’t several of those features require subscription? I believe away mode requires it.

I never cared about that because I want to control tado locally and by doing so those features just won’t work.

If I manually set the Tado to, say, 21ºC, those features will still apply since my tado is connected and registered in the Tado cloud, right?

that heating percentage is useful for this thread’s particular case but for Tado itself there’s no need to use that, it uses that value automatically, right?


It was useful for the o.p. that’s why it was shared.
It’s also useful for me.
If you bought tado earlier than 2 years ago there’s no subscription at all.

1 Like

So thanks everyone for your inputs. Ive take on board and changed the setup (and naming), but it’s still wont trigger the heater. Here is my current code. Ive been playing around with “attribute” and “for” but again the automation hasn’t triggered since last week when i activated it manually. Any ideas?

alias: cinema heater on
description: ''
  - platform: numeric_state
    entity_id: sensor.lounge_living_room_temp
    below: '21'
    attribute: unit_of_measurement
    for: '00:05:00'
  - condition: time
    after: '8:30'
    before: '18:00'
  - type: turn_on
    device_id: f1c514e6de382b1c00cdf53fb3dfb326
    entity_id: switch.display
    domain: switch
mode: single

It was probably below 21 before 8:30.
It won’t trigger again when it gets to 8:30

Use a generic thermostat component.
Then set the mode to auto at 8:30