First day of HA - Tuya issues

Tags: #<Tag:0x00007f327042d390>

Hi All,
This is my first post here, so hello everyone. I hope I will have the patience to stay for longer but my adventure with HA is a struggle from day one. I wasn’t aware that it is going to be so … demanding and random…

After installing HA from image on RPi3 I was pleasantly surprised that Tuya integration was working. Then I wanted to add my IP Camera and it turned out I didn’t have an option of installing add-ons to edit YAML files. I took the memory card, checked files on my PC, the files were not there. When I got my SD card back in to RPi3 and started the system, suddenly I could install add-ons and edit yaml. I managed to add my Dahua NVR feeds in, but then I discovered that all my Tuya devices and weather forecast stopped working. The message I get is:
image

I tried to add Tuya account again, but now it’s saying:
image

I also tried to add Tuya via YAML, no success:

tuya:
  username: xxxxx
  password: xxxxxx
  country_code: 48
  platform: smart_life

Any idea why the integration stopped working? Did it have anything to do with me enabling AddOns?

An update, I configured some of the devices in the Tuya app (previously I used Smart Life), tried to connect, no luck this time too …

… no response so far on the forum, am I posting this in the wrong place? please advise

I managed to resolve this issue by updating DNS server settings in the network configuration. It seems the settings were overwritten during some of the modifications I was doing (I didn’t specifically change them myself).