First time install on dietpi and new to linux

root@DietPi:/etc/systemd/system# sudo systemctl status home-assistant@homeassistant

[email protected] - Home Assistant
Loaded: loaded (/etc/systemd/system/[email protected]; disabled; vendor preset: enabled)
Active: failed (Result: exit-code) since Thu 2019-03-21 13:50:1
8 AWST; 1min 27s ago
Process: 15461 ExecStart=/srv/homeassistant/bin/hass -c /home/homeassistant/.homeassistant (code=exited, status=203/EXEC)
Main PID: 15461 (code=exited, status=203/EXEC)

Mar 21 13:50:18 DietPi systemd[1]: Started Home Assistant.
Mar 21 13:50:18 DietPi systemd[1]: [email protected]
ce: Main process exited, code=exited, status=203/EXEC
Mar 21 13:50:18 DietPi systemd[1]: [email protected]
ce: Unit entered failed state.
Mar 21 13:50:18 DietPi systemd[1]: [email protected]
ce: Failed with result ‘exit-code’.

Description=Home Assistant

ExecStart=/srv/homeassistant/bin/hass -c “/home/homeassistant/.homeassistant”

This is my config


That probably means that /srv/homeassistant/bin/hass doesn’t exist. What does

ls -l /srv/homeassistant/bin/hass


BTW, if you see root@ at the beginning or # at the end of your prompt, you are already a root - no need to use sudo for your commands.

root@DietPi:~# ls -l /srv/homeassistant/bin/hass
ls: cannot access ‘/srv/homeassistant/bin/hass’: No such file or directory

thanks, it my first week into this xD

OK, so the target directory (folder) doesn’t exist. Do:

mkdir /srv/homeassistant/bin/hass


systemctl start home-assistant@homeassistant


systemctl status home-assistant@homeassistant

if everything is OK, then do

systemctl enable home-assistant@homeassistant

to make sure HA starts after reboot automatically

root@DietPi:~# mkdir /srv/homeassistant/bin/hass
mkdir: cannot create directory ‘/srv/homeassistant/bin/hass’: No such file or directory

i am using pi3B+, i use dietpi to install the system,

right now i am trying to do follow this guide to use dock to install hassio

ok i got it working now, with that guide, and a bit help to solve the “[ERROR] Please set machine for armv7l” problem

[here is how it looks in my docker i feel like i installed it twice? -_-](Image and video hosting by TinyPic)

In that case, do it in 2 steps, probably the homessistant direcory does not exist either. The mkdir is a command to create a directory (folder):

mkdir /srv/homeassistant
mkdir /srv/homeassistant/bin

or you can do it in one step:

`mkdir -p /srv/homeassistant/bin

I should have said that earlier, sorry

That will not work. hass is supposed to be the home assistant software, not a directory.

Oh, yeah, sure, without the “hass” part, of course. Apologies. I’ve edited the previous post.

1 Like