First time user newbie : wifi connection

Hi, just trying to start with home asistent.
On my rapi3b 32bit trying to install.

Before on se card: rasbian
Now : hassos flashed with etcher on windows

Network: wifi, wpa-psk 2 mixed
USB stick I tried many things:

  1. different config files (both from here and internet)
  2. different file system (exfat- ntfs - fat32)
  3. case sensitive name of flash (CONFIG vs. config

On my router DHCP there is IP address for raspi3, but since I started to play with hassos there was no renewal.
From router log I cannot see any new request from different device that I have and cane recognize.

Question is: how to debug the installation?
I have connected hdmi.
From what I could see I made little step forward from “link is not ready” to “link becomes ready”.
Under IP address :8123 / mdns target is not accessible and cannot be ping from windows terminal.

Thank you for your help,

So, It seems that I fugure it out.
I will leave it here for good sake of others.

I tried like tens of possible things, but I believe that there was 2 major things beside those mentioned in the hassio guide I did:
1] check your wifi channel. I had auto. Raspi3 can work probably only with 11 channels (one piece of advice I have found here on the forum I think)
2] [connection]
id= value of ID must be the same as the file.

After I did this 2 things I was finally able to restart hasbian and dhcp issued two IPs - 1 per lan, and 1 per wifi.

thank god!!
I hope it will also work for me tommorrow. ;-)))

On second thougth it might be also thing of uuid. At first I was doing things based on video tutorial on youtube, where one of the instructions was generate uuid of your own.
I think, that I used finally one of the UUID from documentation (probably not good idea - i dont know), but try also this.