FitBit unable to authorize


#1

Hi all, I am trying to setup the fitbit component and have followed the directions here:

I am getting the error

The app you’re trying to connect did not provide valid information to Fitbit. Please report this issue to them.
Developer information: invalid_request - Invalid redirect_uri parameter value
On the last step.

Currently my HA is behind Nginx which has SSL and forwards the connection from 443 to 8123 on the HA host.

I have updated the fitbit callback URL to https://myhost.com/api/fitbit but to no avail.

My fitbit.conf settings are correct.


#2

I hit this same issue. I noticed the redirect_uri being emitted from Home Assistant included the port, while the URL provided by the configuration step didn’t.

I updated the application callback URL on the FitBit side of the application setup to include 443 and it work. So i.e. https://myhost.com:443/api/fitbit


#3

would you mind posting your (redacted) nginx configuration for this please? I’m also struggling to get this redirect working.
Thanks