Fix unsupported installation in supervisor


I installed and started using Home Assistant almost 3 years ago on my R-Pi 3. It has worked good for me and I use it for a lot of things. But now I suddenly realized that it says in the supervisor that I’m running an “unsupported installation”. But I used the standard installation three years ago. How can I convert my installation to a supported one? Is it possible or do I need to make a complete reinstall?

This is how it looks in the supervisor:

This are the problems listed:

Thanks for any input!

I can also mention that I’m a bit confused regarding the docker warnings. I thought docker was handled automatically by / home assistant OS? But I see I’m using an old version of docker and if I check the warning for Docker Configuration and that page it says that I should have a “docker” folder in “etc” folder, that doesn’t exist on my machine.

My guess is that you are still using the ResinOS build

1 Like

The easiest way is not to try to fix the issue…create a backup and save it on another system using Samba. Then reinstall HA from scratch using the latest files. When it finally allows you to sign in for the first time :8123 there is an option at the bottom of that screen that says install from a backup or something like that. click on it, find the backup file you just saved. Restore everything except the old version of Home Assistant itself.

1 Like

Ok, I must have misinterpreted what I was using.

Hehe, ok. I figured that it might be the case. So you simply choose not to restore the home assistant version? Is there something about Home Assistant OS or the Supervisor that I should leave alone during the restore?

just use the vanilla restore and don’t check the home assistant box…do a “partial restore”

1 Like

Thanks, I will try it out soon!

It worked flawlessly! Now everything looks a lot better without the supervisor warnings. :wink: Thank you so much!

I’ve bought a new rpi4 8gb
I want to make a new install. But,aparantly the 8gb version is not compatible with 32 bit…
My current install is in a rpi with rpios supervised install. Works well, but’unsupported’…
And when i look in these forums, some versions of hassos won’t start…
Trying top find out what to do.

I think you can do exactly what I did. But try it out first on a spare SD card to verify it before you fry your current setup.
So just make a new setup on a different SD card and the choose backup in the beginning and deselect the top option (home assistant version) and then restore everything else.

Thx! I think i will do that

just follow this guide: Installing Home Assistant Supervised on a Raspberry Pi with Debian 10.

ignore any “not supported messages”…

make sure you have a backup from your old system…and just restore it on your new rpi4 … when you do the restore, don’t restore home assistant itself…but restore everything else.

Very very easy…

Thank you all!