[FIXED] Hard time updating HASS.io to the latest version

Hello all,

I seem to have a hard time updating to the latest version off HASS.io and I have no clue on why that is.
I’m running HASS.io in a vm on ESXi, but I don’t think that should be an issue.

The logging states the following when updating:

19-02-03 10:35:02 INFO (SyncWorker_8) [hassio.docker.interface] Update Docker 0.86.2 with homeassistant/qemux86-64-homeassistant:0.86.4 19-02-03 10:35:02 INFO (SyncWorker_8) [hassio.docker.interface] Pull image homeassistant/qemux86-64-homeassistant tag 0.86.4. 19-02-03 10:35:20 ERROR (SyncWorker_8) [hassio.docker.interface] Can’t install homeassistant/qemux86-64-homeassistant:0.86.4 -> 404 Client Error: Not Found (“no such image: homeassistant/qemux86-64-homeassistant:0.86.4: No such image: homeassistant/qemux86-64-homeassistant:0.86.4”). 19-02-03 10:35:20 WARNING (MainThread) [hassio.homeassistant] Home Assistant is already running! 19-02-03 10:35:20 INFO (MainThread) [hassio.homeassistant] Successful run Home Assistant 0.86.4

Since 86.4 is already out for a few days it should be available I guess…

Any help is appreciated.


Says it’s available but I never got that either. 86.3 was the highest. I’m on 0.87.0b4 now - I don’t think it ever gave us 86.4 even though it’s available.

Something related to 404 Client Error: Not Found (“no such image: during HA or addon upgrade usually signifies about insufficient disk space.

Try deleting something not crucial from sdcard. It could be logfiles, home-assistant_v2.db (history) or backups that have grown too big over time.
Then reboot try upgrading once again.

Had myself occasionally similar issues and could not figure out what happens and then got this hint on Hassio discord channel. Worked for me.
But in long run you should think about bigger storage.

1 Like

Thank you for the responses.

The full disk actually was the problem. I have shut down the VM, grew the disk and booted back up. After that I was able to update to the latest version off HASS.io.
Also cleaning log files wouldn’t have helped as that is in reserved space (for the docker container, not where the images are stored).

@inutilis Thanks a lot!
I had the same issue and your solution worked for me too. :v:

Yes, your solution helped me today aswell. Why does the UI say “Unknown error” when the error is quite simple? This should be a feature request or bugfix.