Flash fails when trying to install on M2 SSD

Newb here, so please excuse me if this is simple.

Went through all the topics, but can’t find an answer to my problem.
I am having problems installing HA.
I have a Dell 3050 i5-7500T. I want to use an M2 (WD SN750) NVMe) which is 500gb (overkill I know) as the device to run HA. It was a previously used M2 memory card, so I cleaned it using Windows and then initialized it and formatted it. I then put it into a M2 external enclosure and tried to install the HA software using the instructions provided on HA, with the generic x86/64 file. I couldn’t get it to flash for several times, as it kept failing. Instead of using the URL method I downloaded the file and used that to install which seemed to work. I then took the M2 drive out of the case and installed it into the computer. I made all the changes to the BIOS and rebooted. It stuck as it started to see the devices, but not the HA operating system it seemed. I then stuck the M2 drive back into the external case and changed the bios to see the external drive and HA booted up fine. I put it back in the computer and changed the bios to see just the M2 in the computer and again it didn’t work.
I don’t understand when I put the WD sn750 in the enclosure it works fine and boots up HA, but when I put it in the computer m2 slot it doesn’t seem to boot up. I don’t want to keep it in the USB port.

Any ideas / help ?
Thanks in advance

Are you sure you saved the BIOS settings after changing that?
Is your SSD in the list of devices for booting from?

I saved the settings. I also looked at the list of devices and it is there. I started all over and wrote things down.

When you boot from the USB, HAOS runs great.
When you take the Ssd from the case and stick it in the dell M2 slot, then change the bios boot settings, when you turn the computer on, you see it start, and all the white writing comes up showing the keyboard, mouse, etc… and stops when it gets to line “1.394984 clocksource: switched to clocksource tic” At this point the HAOS usually starts, but in this case nothing. It just sits there.
In the bios page for the boot options it shows the option “uefi: wds500g3x0c-00sjg0” which is the Western Digital NVMe . That is what is selected.
When you put the MNVe memory in the case and put it in the USB port, then in the bios select the USB port (shows a different name but it is the MNVe card, then it boots up fine.

When you put case in the computers usb port, it shows up in Windows system info PCI information as slot 1 -M2 = Mass storage.

So I cleaned the MNVe card again using Windows terminal using Diskpart and cleaned all. I then flashed the drive (without initializing or formatting the MNVE) and put it back in the Dell computer and it did the same thing.

Does the card need to be formatted and initialized ? I tried that before but it didn’t work.
The computer is older and shows that it works with PCIe-Gen 3. The WD card says it is backward compatible with PCIE-Gen3.
Does the computer just not like the card ? Does the enclosure allow the card to be seen, but when installed in the computer it is not seen ?
I’m getting pretty frustrated with this install, and I’m already down a rabbit hole I didn’t expect.
Thanks for any thoughts or ideas.

Update: I used a different m2 pcie ssd and had the same problems. HAOS boots when the m2 ssd is in an external case plugged into a USB slot, but not when I just take that SSD and put it in the M2 slot on the computer. The bios shows the drive and I only select that ssd for boot, but no luck. I must have a setting wrong somewhere. Can anyone please assist. ?


Is UEFI enabled for that m2 slot?

There is something going on with using M.2 NVME disks. Mine hung on the Preparing Home assistant screen forever. On a whim, I reflashed and used a usb enclosure for my NVME and it booted up in about 10 seconds…

I googled some more and found the problem. In a Youtube post, some made this comment "If it hung on “clocksource: Switched to clocksource tsc” when booting, you have to disable Intel Rapid Storage Technology (RST), dell word it Intel Rapid Restore Technology in their bios. GO into the bios > System Configuration > SATA operation > change to AHCI mode (This is bios for the optiplex 3050). This fixed for me.”

I did exactly that and everything worked great. I’m posting this in case someone else runs into this problem. Thanks for all the comments everyone !


This fixed my issue also.

Me too.
After HOURS of trying, this fixed ir!