Flashed Tuya Gas detector with ESPHome

And it does not work, well it work but it cant read any sensors. When running ltchiptool it says that it uses TuyaMCU. So I tried OTA firmware upgrade with OpenBK (that supports TuyaMCU) and tried all the three different firmware files (*.rbl, UG and QIO .bin) but it gives me the error “Update Failed: Bad Magic Number”.

Is there a way to do a OTA upgrade and switch to OpenBK for as it is right now its only a cup warmer

Or if someone have the config for it so I can use ESPHome?
It is this: SMARTROL tuya Natural Gas Sensor Combustible Household Smart LPG Gas Alarm Detector Leakage Sensor Wifi Temperature Detectors - AliExpress

You need to convert to uf2 using ltchiptool

Still issue thou

Followed the guide and ran:
‘/home/XXXX/.local/bin/ltchiptool’ uf2 write -b generic-bk7231n-qfn32-tuya -o /tmp/OpenBK7231N_1.17.224.uf2 ‘OpenBK7231N_1.17.224.rbl=device:download’

FileNotFoundError: [Errno 2] No such file or directory: “'OpenBK7231N_1.17.224.rbl”

Ahh It works different in Windows:

Correct syntax for Windows
ltchiptool uf2 write -b generic-bk7231n-qfn32-tuya -o C:\temp\OpenBK7231N_1.17.224.uf2 OpenBK7231N_1.17.224.rbl=device:download

@tellblom Does it mean, this device now works fine for you with ESPHome? Can you share your ESPHome YAML file? I have just purchased the device and want to convert it as well.

No I never got it working in ESPHome, I used OpenBK and got it working with that and MQTT.
I am not home right now but I can share the “tasmota” config when I get home if you want.

Please do, if it is not a problem.