Flashing ESP32

I have tried two ways to flash my ESP32 dev board, but I have a com issue in both cases.

  1. Hassio with ESPHOME add-on. I plug the board directly into raspy 3b+ running hassio with add-on, restart add-on, but I cannot get Serial USB option in ESPHOME, so no joy.
  2. ESPHOME-Flasher. I have installed the esphome-flasher for mac. I compile and download the bin, but the esphome-flasher on my iMac cannot detected a connection.
    These problems probably have very different solutions. Any help would be appreciated!

Thanks so much for replying. The Hassio is running on a raspy 3b+. Locally I am running on an iMac running Catalina.

Take note of the second part of that post. It applies no matter how you are running home assistant or the flashing tool.

Sorry Tom, when I looked at your post I didn’t click on it, which applied the formatting.

However, my ESP32 isn’t behaving as you describe in either situation. I have two buttons, a boot and an RST button. I’ll describe the esphome-flasher result. I plug in the device on the imac. I have esphome-flahser running. I press both buttons, count to 10 and release the RST button. It doesn’t matter when or how many times I try to refresh the serial port list - it never comes up. It doesn’t matter the sequence of button release.

I think that for the mac there may be a missing driver to see/mount the device.

If anyone can help me get the ESP32s flashed by either method I would be grateful.

I still can get this thing into flash mode. I am trying directly plugged into the Pi3b+ running hassio with the esphome add-on.

Did you press the flash button on the device.

When you plug it into the rpi, does dmesg tell you it has been seen by the kernel?

I seemed to have solved this on the rpi. I tried every USB cable in the house and one worked. Really bizarre.

I have bought an ESP32 from China (model ESP32-CH9102X as I tought newer is better).
Unfortunately I can’t flash it from ESP Home installed on HA like I did with other 2 boards.
HA is installed in RPi4.
The error I am getting is this one.
On Aliexpress is mentioned I need to flash it from windows.
This is something new for me…and have no idea how to do it.

A fatal error occurred: Invalid head of packet (0x65): Possible serial noise or corruption.
INFO Upload with baud rate 460800 failed. Trying again with baud rate 115200.
esptool.py v3.2
Serial port /dev/ttyACM1
ERROR Running command failed: device reports readiness to read but returned no data (device disconnected or multiple access on port?)
ERROR Please try running esptool.py --before default_reset --after hard_reset --baud 115200 --port /dev/ttyACM1 --chip esp32 write_flash -z --flash_size detect 0x10000 /data/esphome4-living/.pioenvs/esphome4-living/firmware.bin 0x1000 /data/cache/platformio/packages/framework-arduinoespressif32/tools/sdk/bin/bootloader_dio_40m.bin 0x8000 /data/esphome4-living/.pioenvs/esphome4-living/partitions.bin 0xe000 /data/cache/platformio/packages/framework-arduinoespressif32/tools/partitions/boot_app0.bin locally.

Problem solved by flashing the esp32 from a PC.
LE: The PC was with Windows 10, not the RPi4.

how else would you flash it?

From Rpi4, like I did with the others 2.
But for this one was not working.

Of, suddenly the rpi is not a computer? No-one told me :slight_smile: