Flashing SD Card fails at verifying but writes some partitions


I’ve been using HA for the past couple of months and have moved from a QEMU on Linux to a dedicated raspberry pi 4 and couldn’t be happier EXCEEEPT that I just got a couple of brand new larger SD cards and I wanted to transplant everything to one of them and in the process I convinced a friend of mine of getting his own pi4 with HA, the problem comes when trying to flash HA to the SD Cards, I see an odd result:

No matter what software I use it will always fail at verification, tools I’ve used:
Etcher (Linux & Mac)
Raspberry Imager (Linux & Mac)
Rufus (Win10)
Linux’ dd

I’ve used a total of 12 SD Cards from different vendors and 8 different adapters, I’ve also tried using the integrated ports.

It’s always the same result:
Shows up only 2 partitions as mountable (Kernel and System)
If I then go to Terminal and run fdisk I’ll get the warning that the partion table is corrupted and if I create a new table (dos) I then magically see the boot partition mountable, everything else is gone.

With all cards I’ve tried reformatting, 00’ed them with dd, fdisk, and everything. I do not understand what’s going on.

Could the img file be corrupted from source?