Flashing Smart Switch

I`m using 10+ wifi switches flashed to tasmota in my home automations. I ordered a couple of new ones by Lonsoho with physical buttns to replace Sonoff T1 with touch buttons that are pretty annoying.
And now I’m having issue with flashing new ones. OTA Tuya convert doesn’t work, thus I’m looking for solution with UART\soldering. I searched for pinout even on tuya developers guides, but can’t find any reliable information about pins. I tried most common combinations for pins ( 3,3v, Rx, Tx, GND) for pins 1-6 but nothing worked.

pcb is marked as:
20200817 v1.0

Can anyone help with this?


A pic of the other side of the board may help. I presume the actual chip is on the other side?

Is that not a Zigbee switch?


Nope, it is actually Wifi + RF version. There is esp8285 onboard (near the pin holes)

Other side is here:

Can you access those pins at all whilst the board is connected up as normal? (perhaps run wires out from it). That way you could test for voltage and at least narrow it down by working out the 3.3 and GND connections.

Also, rather than worrying about a pinout for the board, look up the chip pinout (although I think you have tried that). From there you can visually trace which pins go to the connections you are using.

Hi Dave, I connected the device and tried to measure the voltage on the pins. You can find results on the pic below.
And, yes, I tried to trace the pins. Rx and Tx pins are easy identifiable. But GND and +3,3V can`t be traced at all ((.

That pic creates more questions than answers! I’m not sure what you are trying to show with that…
It’s hard to tell with such a dark circuit board but it looks like 1 is GND. Using that as a start, what voltage do you get from 1 to the other pins ?(other than what you know are TX, RX)

@qwazag did you manage to find out how to flash that switch? I have the same board from a different manufacturer but I’m struggling to flash it with tasmota…

Looks similar to this one

1 Like

This was probably the only combination that I haven’t tried. Thank you very much!