Flashing tasmota problem

Tags: #<Tag:0x00007f738df8c840> #<Tag:0x00007f738df8c598>

Hi there. So I am trying to flash tasmota using tuya-convert on a esp8266 - Awow EU3S smart plug (to make sure that it is really esp8266 i opened and checked, it is). The device connects fine to Smart Life app or Tuya app. I am running home assistant on ubuntu on an intel nuc.
The problems:

  1. If i try to ./start_flash.sh from ssh connection, like my windows pc, it asks me to terminate systemd-resolve (port 53) and mosquitto docker-proxy (port 1883). after i click Y for yes, it all stops in the ‘Starting AP in a screen’ text and never actually gives the intructions + the ability to press enter to flash anything. Cant connect to HA from a browser or app also, so it basically crashes for some reason. In this case I have to restart my intel nuc.
  2. If I am directly on my intel nuc, the screen loads, gives instructions, but never flashes anything. In /scripts/smarthack-udp.log I get all kinds of different device key’s, id’s, different ip addreses and all of them say that the chip is not esp8266 (which it definitely is).

Some ideas I have, but cannot check for sure:
Is my phone somehow connecting wrong to vtrust-flash AP? Im an iphone, but I did try a samsung tablet.
I have a wyze sense hub plugged in my intel nuc and a conbee 2, maybe they bother this process? However, I tried removing them from the usb ports and still same result.
Is it a problem that I do not have an external wifi adapter? I was thinking that the one inside intel nuc is good enough.

Any help is much much appreciated, I have been stuck with this for days and I tried everything I could come up with.

First of all, I wouldn’t run tuya-convert on the device I’m running HA on.
Second, if tuya-convert does not work, it can be that your smart plug has the latest tuya firmware, and tuya-convert does not work on the latest firmware.

1 Like
  1. Why?
  2. Where do you find this information?

1/ Why :
tuya-convert disables dns and mosquitto while running, both things are unacceptable if I want to keep HA running.

With this I can’t affort to have mosquitto disabled
image

2/ https://github.com/ct-Open-Source/tuya-convert/issues/483

I have read through the topic multiple times yesterday, and again today when you gave me the link. It still does not seem clear enough from which version the device cant be flashed anymore. I have version 1.0.0. I do thank you very much for your help.

If this is the case, do you have any idea which EU plugs are compatible with tuya-convert that I could buy now on amazon or elsewhere? Because in tasmota site, my plugs are compatible, thats why I bought them…

Just checked

it says :

This device was flashed via serial port but probably could have been flashed with Tuya Convert.

Since it is open already, why you don’t try serial flashing ?

in the scripts directory of tuya-convert there is a file called smarthack-psk.log
open it and if you find entries of the id: beginning with o2, then it will be unable to be flashed by tuya-convert at the moment due to new firmware

1 Like

Well, lets just say the taking apart process was not easy and device is beyond repair now.

I think it is 02, o2, but that is probably what you meant, and yes, all the entries there start with this id. However, as I understand, it is possible that with future tuya-convert the flash might be possible?

it maybe, but not at the moment.
If you already have it open, i would flash it directly via serial as francis said

yeah, like i said, the device was destroyed in the process of disassembly.