Flic2 integration - buttons lose connection after certain time

I am on HassOS using the latest flicd add-on (version 1.3.1).

My set-up is working for five Flic buttons of which three are Flic2 and two are orginal Flic.
However after some time, somtimes 1-3 days sometimes 1-3 weeks, the buttons seem to lose connection with hassio. I can’t see anything wrong in the logs. However pressing the btuton will flash red.

Rebooting hassio will get it back up running again and then it will work for additional days before same problem. Just retsarting add-on is not sufficient to get it back online again.

I saw previously someone mention to set discovery to false which I have done but still same result.

Anyone else with this problem? Any solution?

Boy I wish there were small zwave buttons instead, that network is rock solid compared.

No such thing. It’s called home assistant OS.

Sorry little quick on the fingers. HassOS.

That’s the operating system, not install type.

I think it’s pretty clear what I am using… it would be more helpful if you would actually try helping with the actual problem… :slight_smile:

Do you have discovery set to false? it helped fix most of the issues.

You can set it like this:

  - platform: flic
    discovery: false

You say that but you still have it incorrect even after I told you:

Being able to describe your operating environment correctly is important in obtaining a solution.

That’s what he said:

I am having the same issue. the flic button would display a red led light when clicked at 1st but then after couple clicks it will connect to home assistant. any idea on how to keep the connection between the flic and home assistant alive?
Please any help would be appreciated.

thank you

I’ve worked through two different problems with my Flic buttons.

  1. I had the same issue as described by the OP, my five buttons would work for some period of time – usually a small number of days – then all stop working. I would have to shutdown&restart both Home Assistant and the flicd service, in a specific sequence1.

I tried two Broadcom BCM20702-based Bluetooth adapters from different manufacturers, both suffered the same issue. (Also tried one or more Bluetooth 5 controllers, but they didn’t work at all)

What finally solved this issue was changing to the recommended (and pricey!) Sena Technologies Parani-UD100-G03 adapter. However…

  1. A new issue that followed was that individual buttons would randomly lose their connection after some hours or days. I initially assumed the new adapter couldn’t handle more than four connected buttons at once, though that proved to be untrue.

Getting a button reconnected required merely holding the button on for the 7 second discovery period. Not difficult, but annoying, especially for family members less invested than myself.

It was this forum thread that solved that annoyance. After the final change to the UD100-G03 adapter, I had left discovery enabled. Changing discovery to “false” has made the buttons rock-solid stable, going on a month or so now.

1 I run Home Assistant in a Virtual Box VM within a Linux host, while the flicd service is run outside the VM, and thus must be restarted separately while Home Assistant is down.