Flooded by Shelly integrations

Discovery -> ignore doesn’t work with Shelly integration.

Was there actually a shelly integration before this or were they setup manully via mqtt? as the integration says it appeared in 0.115

There has never been anything like previous Shelly integration. This is the first time Home Assistant supports Shelly devices.

yeah i just checked, so the integration is working as intended. If setup manually via mqtt then the only way is
a. Disable/remove zeroconf
b. ingnore warning about finding the shelly devices
c. hit ignore for each one and no more notifications

Remove the shelly mqtt setups and use the integration and configure them

I don’t understand what you’re saying. There is no shelly_mqtt integration in the HA. There was a project of such an integration but it wasn’t completed. MQTT integration has nothing to do with Shelly integration.

the shellys would have been setup using mqtt manually

he meant shelly devices configured as mqtt entities. You should know the best that such option exist and a lot (if not most) of users use shellies this way.

the other option maybe that mdns service can be disabled on the shelly devices?
i dont use them so unfamiliar with their intrfaces

thanx for suggestions
Those options are obvious (besides I don’t know how exactly to execute a) )
but it all seems to be workarounds. Knowin that component can be configured multiple ways it should be programmed/configured in a way which not bother the user without reason.

BTW HACS has a feature “hide all new integrations” which might be one of way how to solve it. Still I’m not sure it’s the best.

the other option maybe that mdns service can be disabled on the shelly devices? i dont use them so unfamiliar with their intrfaces

There is something like this. I can try it - thanx for the tip. However it potentially limits device functionality so I wouldn’t consider it as a solution. But it would work for me

Yes but it’s not related with the “flood problem”.

It is.
If someone has configured devices using mqtt he obviously is not intrested to configure them again using shelly integration

Problem is i don’t think there is anyway to distinguish between the integration and the mqtt setup. i coulnt see how its possible for the integration to know a mqtt device is the shelley in question or vice a versa

Looking at the api docs, i think you maybe able to stop them being discoverable, it maybe an option to try that on a single device to see if works


scoll down in the setting area for discoverable

This option may helps

Yes it might work. And I’ll apply it for sure.
But one may use mdns for his reasons.
In general an application shouldn’t force an owner to disable features of his devices in order to dodge questionable design choice.

So rather than clicking “Ignore” multiple times in one place, you are going to log into that many devices and set them undiscoverabe?

Seems like a lot more work to me.

Just click the ignore buttons. it’ll take you 30 seconds tops.


I dont think its a questionable design choice, the discovery is there to help people add their devices to their system easily. you either turn of discovery at the HA level or the endpoint, setup the device using integration or set them to ignore. as tom said the easiest solution would be to ignore and thats why the option is there

you are right. It’s impossible.
But IMO it’s bad decission to enable zeroconf for shelly integration knowing how many users have those integrated through mqtt. The impact on user experience should be easily predictable.

BTW I don’t know why Maciek said there was no Shelly integration before. I’m sure it was. It was called ShellyForHas. But stopped working with shelly fw geater than 1.8. Then Maciek created new, official integration (maybe pld one was in Hacs, don’t remember)

But disabling it would then stop the device from being discoverable which when onboarding new users is a preferable option to show them all the devices they can set up

That would have been a custom integration

it’s questionable considering wide use of mqtt.
And annoying for users who have alredy configured tents if those devices. Clicking 100 times on ignore and next 100 times on confirm button isn’t the proof of good application design.
I admit however that it makes things easier for people just starting with those devices.

I’m not sure. A lot of integrations require adding integration explicitely (bit orange + button). Such approach gives an option of using the integration consciously. (or not using if not needed). Why not fo that this way for Shelly?