Flooded by Shelly integrations

I just updated to v0.115.6
Is it really how lntegrations screen should look like? it was never showing new devices until integration has been explicitely added. But I’m sure I’ve never added Shelly integration (neither old nor new one)

I was trying to figure out how to enable the Shelly integration, but it just seems to be included. I would love someone else to chime in, I’m not certain my conclusion is right. Looking at adding 2 Shelly Duo Bulbs I recently got.

Yes it is included in the home assistant core. Just add the integration with the (+) icon. Or don’t. Considering the issue above and that others have reported connection stability issues. Though there is a fix for that I don’t think it has been released.

Thanks for the info, not I don’t have to figure it out!

I’m still interested in how to disable the Integration I’ve never added.
I’m have all my shellies configured manually through mqtt.

Click all the "ignore’ buttons.

You mean 30+ times?

I think shelley use mDNS so HA will pick them up as part of discovery. thats why they are listed but not setup
The integration would have the zeroconf enabled in its manifest

It does have zeroconf enabled for the interation
“domain”: “shelly”,
“name”: “Shelly”,
“config_flow”: true,
“documentation”: “https://www.home-assistant.io/integrations/shelly”,
“requirements”: [“aioshelly==0.3.4”],
“zeroconf”: [{ “type”: “_http._tcp.local.”, “name”: “shelly*” }],
“codeowners”: ["@balloob", “@bieniu”]

Thank you for response.
Is it how it shold be? I mean is it in compliance with HA new devices integration policy?
I’m sure I have to opti-in explicitely if want to use other integration. So it seems to me like an exception.

But more important how can I disable it? There are new items over and over again once I add new shelly to the network.
Maybe @Bieniu could help

Use ignore button.

Bieniu, I asked multiple questions but you came with one suggestion I can treat as temporary workaround but not serious solution.
I have tents of those devices and number is growing. In addition Every ‘ignore’ request require confirmation Are you expecting every user will be clicking 100 times (and more if connecting new devices)? Is there a plan to fix this or add an option to get rid of this unwanted integration?

You don’t have to use Discovery.

I don’t know, I think not because user can ignore the unwanted device.

Can you elaborate more? I didn’t enabled discovery or whatever it is.
The point is that Integration I’ve never enabled requires some actions from me (a lot of them). I decided to use Shelly with mqtt. I’m not interested in using Shelly integration.
BTW previous version of the integration didn’t annoy a user like current one. So it’s definitely something new added to integration by you.

Discovery is a part of default_config https://www.home-assistant.io/integrations/default_config/ so you have to remove it from your configuration.

You mean this page https://www.home-assistant.io/integrations/ssdp/?
Shelly integration is not listed here.
And there is no information how to disable it.

I can see the point. Some one was thinking that it’s nice to automatically show newly added devices. The problem is with devices which can be integrated multiple ways (in that case: MQTT or Shelly integration). It doesn’t play this time. And should be fixed somehow. Specifically would be nice to have option to disable selected integrations.

Edit: I was thinking I found the way: https://www.home-assistant.io/integrations/discovery/ but cannot figure out how to disable discovery for shelly since (again) Shelly is not listed on integration list. I tried shelly and Shelly but both fail:
Invalid config for [discovery]: value is not allowed @ data['discovery']['ignore'][0]. Got 'Shelly'. (See /config/configuration.yaml, line 5).

Your problem is not related to Shelly integration but to discovery/zeroconf. You have to disable discovery/zeroconf components.

Not all integrations have zeroconf enabled in manifest (incl previous shelly integration). The new Shelly integration has. So yes, this is the integration issue.

I asked for help in disabling it. Reference manuals don’t help.

No, it’s not. If a device matching the integration requirements is detected, the entry for that device appears in Integrations. User can configure this device or ignore it. This is how discovery/zeroconf works in Home Assistant.

I already wrote to you that you have to remove default_config from your configuration to disable discovery/zeroconf.

I dont think the previous shelley integration was config flow based so would not have had zeroconf enabled to be automatically picked up - i could be wrong here
The idea i believe is the integration has zeroconf enabled if it supports it so that it is found by default, the only way to stop any integration being found would be to remove zeroconf from your setup.

I dont believe there is any other choice other than that or ingore them entirely and see messages about them being found or set them to ignore individually for each one

That is for integrations that dont use zeroconf, a number of them have been migrated (axis, esphome) to use zeroconf so they are no longer listed. that is why the shelly integration doesnt appear there