Floor plan image wont display in picture elements or glance using lovelace

floor plan image wont display in picture elements or glance using lovelace.
I have read a lot, have tried a few things, no success.
Frustration has set in so time to ask for help.
I have a floor plan image fplan1.png
I have created a config directory in homeassistant directory with a www folder under config.
I have tried /local/fplan1.png
I have tried /config/fplan1.png
have tried /config/www/fplan1.png
have tried /home/pi/homeassistant/config/fplan1.png
have tried /home/pi/homeassistant/config/www/fplan1.png

I also tried creating a config dir and a config/www directory under root with the fplan1.png file in there. Each time I restart home assistant.

this is the code from lovelace editor

elements:
  - entity: sensor.ent_temp
    style:
      left: 40%
      top: 32%
    type: state-badge
image: /local/fplan1.png
type: picture-elements

I am using homeassistant 0.108.3 in a docker container on a pi3

thanks
Ian

if I use http://ip add:8123/local/fplan1.png in my browser I get a file error 404
so for some reason it is not resolving the /local ?

Any help out there. I’ve exhausted trying to find a solution. Cant be the only one looking for a solution surely

think I will give up on home assistant, little support

Mine is in /local/floorplan.png … How did you upload it? Did you check permissions?

Hello Brandon,
thanks for the info

I created a local directory under the root directory and copied the file to \local
same result wont display
the ownership of the file is pi. Is that correct?

-rw-r–r-- 1 pi pi 381741 Oct 26 23:46 fplan1.png

thanks