Floorplan for Home Assistant

@hijinx Oops… my mistake. Now renamed to frontend.yaml

1 Like

Did you find the solution for this?

Hi there,

Floorplan is working for me within the Custom Panel and the overview but not as a state card. Copied all the relevant files and code into the configuration.yaml and into the specific folders on my RPI

Any ideas?

Thanks in advance


Im having some trouble getting this to work.

I know the www folder needs to be in /home/homeassistant/.homeassistant

The issue I’m facing is when I set up home assistant yonks ago I didn’t set it up using “homeassistant” as my username.

My current hass path is /home/synertia/.homeassistant

Can anyone help me getting the floorplan to display? I have tried typing in a full custom path in the floorplan.yaml file as

 name: Demo Floorplan
       image: /home/synertia/.homeassistant/www/custom_ui/floorplan/floorplan.svg
       stylesheet: /home/synertia/.homeassistant/www/custom_ui/floorplan/floorplan.css

But that doesn’t seem to work, the floorplan pannel just spins around a multicoloured wheel and eventually says “error loading stylesheet”

Any help appreciated please :slight_smile:

Just to add, I don’t think this is a path issue

As if I stick with the default paths in the config files /local/custom_ui etc etc. If I go to my web browser and type in


I can see the svg file in my browser.

If I try and load - http://has01:8123/local/custom_ui/floorplan/ha-floorplan.html

This file just displays a white page

Any ideas why the floorplan isn’t showing on a custom panel? I cant work it out…

@Ross_Davey and @Thorbeen,

I believe there is currently an issue with HA and custom state cards. The issue is described here:

Would any of you be able to test the custom UI to see whether the symptoms are the same as what you are seeing with floorplan?

I haven’t used a custom state card, I have set it up as a panel…

Hi there,
since a week I’m having this error in the Floorplan card:

Uncaught TypeError: Cannot read property ‘attributes’ of undefined


Any hint on where I should look for an error? The message is not helping, and the HA log shows nothing. The floorplan is working correctly.

Hello @pkozul , was wondering if you could give us an update regarding dimmer support? Is this still on the todo-list?

@Thorbeen, what app did you use to draw your floorplan?

@Thorbeen to me it seems an error in groups configuration. I can replicate it with this configuration:

  name: test_view
  view: true
    - binary_sensor.floorplan

To make it work as intended you have put the Binary Sensor in a group:

  name: test_view
  view: true
    - group.floorplan

  name: Floorplan
    - binary_sensor.floorplan
1 Like

Im still having issues with using a custom panel rather than the front end view

Any updates on why its not working for me?

@Ross_Davey, I have the same behaviour: http://has01:8123/local/custom_ui/floorplan/ha-floorplan.html displays a white page. It is the normal behaviour.

Did you got the latest version of Floorplan? Your issue looks similar to last month’s safari bug. Also check the name of the frontend file, it was recently renamed from frontend.html to frontend.yaml.

My suggestion is to download again the Floorplan zip from github, and redo all the configuration steps as there have been some changes in the last weeks to make it compatible with the changes in HA 0.53.

As far as I can read from the instructions, the frontend.yaml file is only needed if your using a custom card on the front end so I cant see that this is whats causing my issue.

Im not using a custom pannel on the front end. I am using a custom panel as you can see in my screenshot

The coloured wheel just keeps spinning

Can you try in a Private Window in Safari and/or another browser? It may be invalid cache

Other questions to help debugging:

  1. Can you try with Chrome?
  2. Any error in console? (Safari -> Preferences -> Advanced -> Show Develop menu, then Develop -> Show javascript console)
  3. Version of HA and version of Floorplan?
  4. If you setup Floorplan as a state card, does it work?

I have access to both a mac and PC.

Same issue across all browsers.

I am running HA version 0.53.0 and downloaded the latest version of floor plan as of Sunday.

I haven’t tried a state card but can give it a go

For everyone with problems
In Chrome: Website information (fav-icon) -> Cookies -> delete Service Worker and Local Storage -> Ctrl+F5


Attempting to use a custom state card as outlined on the GitHub instructions in “Option 1: Floorplan custom state card”

The card shows up but is BLANK! Can anyone tell me where fronted.yaml is meant to go and how you reference it in the code? No where on the GitHub page mentions where it goes or what to do with it…

Ok Ive fixed the floorplan custom panel from my original issue.

What I now cant get working is the front end panel…shows as blank