Flow does not run on state change while trigger/stoptimer is running

The node-red flow works fine, turns on the switch on motion, and then turns off after 60 sec. However, I’m trying to get the timer to reset if the motion is retriggered. While the timmer is running, the flow does not capture any motion events. I have tried both trigger node and stoptimmer but the result is the same.

[{"id":"dce58caf.1985c","type":"server-state-changed","z":"5de2fd93.554e34","name":"","server":"78f33113.8072","version":1,"entityidfilter":"binary_sensor.staircase","entityidfiltertype":"exact","outputinitially":false,"state_type":"str","haltifstate":"","halt_if_type":"str","halt_if_compare":"is","outputs":1,"output_only_on_state_change":true,"x":230,"y":120,"wires":[["ff07bd0.391f24","4fa5734f.1d094c"]]},{"id":"399fe53b.24519a","type":"switch","z":"5de2fd93.554e34","name":"","property":"payload","propertyType":"msg","rules":[{"t":"eq","v":"on","vt":"str"},{"t":"eq","v":"off","vt":"str"}],"checkall":"true","repair":false,"outputs":2,"x":570,"y":280,"wires":[["69a0231a.4ad04c","2d01d918.bda666","5a420ef5.fa313"],["5a420ef5.fa313"]]},{"id":"69a0231a.4ad04c","type":"api-call-service","z":"5de2fd93.554e34","name":"","server":"78f33113.8072","version":1,"service_domain":"switch","service":"turn_on","entityId":"switch.family_room_lamp","data":"","dataType":"json","mergecontext":"","output_location":"","output_location_type":"none","mustacheAltTags":false,"x":830,"y":120,"wires":[[]]},{"id":"c24b6325.26cea","type":"api-call-service","z":"5de2fd93.554e34","name":"","server":"78f33113.8072","version":1,"service_domain":"switch","service":"turn_off","entityId":"switch.family_room_lamp","data":"","dataType":"json","mergecontext":"","output_location":"","output_location_type":"none","mustacheAltTags":false,"x":870,"y":440,"wires":[[]]},{"id":"ff07bd0.391f24","type":"debug","z":"5de2fd93.554e34","name":"","active":true,"tosidebar":true,"console":false,"tostatus":false,"complete":"false","x":550,"y":60,"wires":[]},{"id":"4fa5734f.1d094c","type":"api-current-state","z":"5de2fd93.554e34","name":"","server":"78f33113.8072","version":1,"outputs":2,"halt_if":"on","halt_if_type":"str","halt_if_compare":"is","override_topic":false,"entity_id":"input_boolean.automations","state_type":"str","state_location":"","override_payload":"none","entity_location":"","override_data":"none","blockInputOverrides":false,"x":240,"y":220,"wires":[["6e8b3cd5.4cc554"],[]]},{"id":"6e8b3cd5.4cc554","type":"api-current-state","z":"5de2fd93.554e34","name":"","server":"78f33113.8072","version":1,"outputs":2,"halt_if":"on","halt_if_type":"str","halt_if_compare":"is","override_topic":false,"entity_id":"input_boolean.family_room_lamp_mode","state_type":"str","state_location":"","override_payload":"none","entity_location":"","override_data":"none","blockInputOverrides":false,"x":260,"y":340,"wires":[["399fe53b.24519a"],[]]},{"id":"2d01d918.bda666","type":"debug","z":"5de2fd93.554e34","name":"","active":true,"tosidebar":true,"console":false,"tostatus":true,"complete":"true","targetType":"full","x":850,"y":240,"wires":[]},{"id":"5a420ef5.fa313","type":"stoptimer","z":"5de2fd93.554e34","duration":"60","units":"Second","payloadtype":"num","payloadval":"0","name":"","x":790,"y":320,"wires":[["c24b6325.26cea","5f852767.77c3d8"],[]]},{"id":"5f852767.77c3d8","type":"debug","z":"5de2fd93.554e34","name":"","active":true,"tosidebar":true,"console":false,"tostatus":false,"complete":"true","targetType":"full","x":700,"y":580,"wires":[]},{"id":"78f33113.8072","type":"server","z":"","name":"Home Assistant","legacy":false,"hassio":false,"rejectUnauthorizedCerts":true,"ha_boolean":"y|yes|true|on|home|open","connectionDelay":true}]

Uncheck this:
image

No luck! Even after unchecking and deploying its the same behaviour. I’m running everything as docker containers, but that shouldn’t have any issues.

Anyways, does anyone have it working please share your flows.

Resolved!
It was not related to Node-Red, HA, MQTT (Checked each component)

It was BlueIris (Camera Software) which had a setting not to re-trigger again within 1 min. Disabled it and its working now.

I was just about to reply with another idea. I’ll still mention it even if it is fixed.

Do you need that switch node? I see that it is passing along off and on states, but you only have the “on” states from your input booleans connected. I think you can do away with it and further simplify your flow.

Makes sense, I will give it a try. Once again Thank a lot.