FluxLED / MagicHome issue with certain controllers

I have several MagicHome based RGBW Wifi controllers that work well. I recently ordered a pack of 4 more, and those are barely working within Home Assistant at all. The UI within the MagicHome app is different for the new ones, but otherwise they work fine in the MagicHome app. From Home Assistant, I can turn them on and off (even though it says “Failed to call service light/turn_on” and doesn’t change state immediately) but cannot change colors or send any other commands to them (get same error message). I have tried adding the ‘ledenet’ protocol without any change.

The older controllers that appear like this in the app work well:

The newer controllers that appear like this do not work:

When I view device settings within the app, the older controllers (a couple years older) display the MAC address followed by a “v4”, where the newer devices are followed by a “v1”. Not sure what that version number is for. The older controllers have a firmware version of 4.v4.17.6445-A and the newer ones have firmware 6.v1.2.7386-A.

Any ideas why Home Assistant cannot control or set colors for the new controllers? Is there another protocol I could try, or any other ideas to get them working?

1 Like

I’m interested in this too as I am in the same boat. I used to flash them with tasmota, but couldn’t be bothered to do this on the RGBW, though I may have to.

I purchased the exact controller linked to from the Home Assistant Flux LED documentation page (https://www.home-assistant.io/integrations/flux_led/ which links to https://www.amazon.com/dp/B01JZ2SI6Q/ref=cm_sw_em_r_mt_dp_GCJ0YJFCPCJKJZQE70ES) and it does not work in Home Assistant. It has the same interface as the “newer” interface I posted above in the Magic Home app. I can turn it on or off, but nothing else (no brightness, color, etc).

I did crack it open and this one has the ZJ-WFMN-A V1 board, which I believe means I can flash it with ESPHome based on this thread (Magichome devices work PERFECT with homeassistant (reflash this code with ESPHOME)). Unfortunately my other 4 have ZJ-WFMN-E VL1 boards, which my understanding is they have a different chip and cannot be flashed, and therefor are essentially useless for any kind of Home Assistant integration.

All of this is making it very frustrating and difficult to try to get LED strips integrated into HA. I have no idea what/where to buy to get a controller that will work out of the box, versus one I have to flash, versus one that will just not work at all.

I believe the tuya zigbee led strip controllers work native with HA using the tuya integration, you’ll need a zigbee coördinator like a conbee stick through.
I havent tested it. There’s never a guarantee that you buy a magic home device that’s flash able, youll need to open it up to check. As long as it has an esp chip, it can be flashed

Do you know if there is any alternate way to use the ones that don’t have an ESP chip? The ones I originally bought quite some time ago worked fine in both HA and MagicHome without flashing anything on them. I assume they had a firmware version that was compatible with FluxLED out of the box and HA was communicating directly with the device. I previously assumed it was integrated with MagicHome via API but now I realize that assumption must have been wrong.

Would it be possible to create a new protocol for FluxLED to communicate with these other devices?

These should be fixed in 2021.11