Forcing update

In 0.75.0 the tab was broken. I’ve open an issue and it was promptly closed telling me is fixed in 0.75.1
Problem is, SSH is broken too - getting a ‘Connection refused’ error (it has been working forever, maybe an addon update brokeit)

So: given I can’t update via the tab nor via ssh, is there any other method? like calling a service from the web interface or other magic? otherwise i’m pretty f*ed up


1 Like

HassOS or ResinOS?

You need an authorized_keys file

With ResinOS, you need to copy it to the Resin_Boot partition on a computer; with HassOS you need a USB with the volume label CONFIG (Uppercase) and then reboot the Pi.

Then you have ssh access on port 22222 (use root as username in the settings) use the private key for auth.

Then from ssh, issue this command:

Hassio ha update

When it’s done it’s magic reboot and you’re good again.

Let me understand. Here you are trying to fix ssh? Using keys recently became a requirement? Because ssh worked and I’m quite sure I was just using username/password

Clearly your ssh is not working for some reason - using an authorized_keys file will give you access to the host - it’s a get out of jail free card. It’s not mandatory for normal ssh but given it’s not working for you it’s an option that will work.

Edit: for debug mode on port 22222 it IS and always has been mandatory. Debug mode will save your arse.

Got it thanks. I’ve just tried 22222 instead of the default, just for the sake of it, and got

[email protected]: Permission denied (publickey).

But the UI (the tab). It must be calling some rest endpoint to start the update right?

Unless you actually created an authorized_keys file as I described above, why would you expect it would connect?

thanks David, it worked, and I’m back to a working hassio. :tada:
just a note. after gaining ssh debug access, I had to do this:

docker exec -it homeassistant /bin/bash
curl -d '{"version" : "0.77.0"}' http://hassio/homeassistant/update

now. I understand I need to enter a running docker container
what I don’t get is why the hassio command was not available even there

also, I’m not even sure the whole ssh debug was needed, as calling the ‘http://hassio/homeassistant/update’ was probably enough and I could have done it in a normal shell