Foxess AIO-H3-8.0-E Inverter

Hi Guys,
in this energy crisis, I installed an Foxess All in one inverter with battery.
Now, I want to integrate it in home assistant. preferable locally.
The inverter is connected through ethernet cable.

I tried both the cloud integration and the local modbus integration. neither seems to work.
Local: GitHub - StealthChesnut/HA-FoxESS-Modbus: Home Assistant Modbus Integration setup for Fox ESS H1 and AC Inverters
Cloud: GitHub - macxq/foxess-ha: Home Assistant & FoxESS integration. Monitor you photovoltaic installation directly from HA ☀️ ⚡️

I get following errors in home assistant:
Local integration: Pymodbus: HA-FoxESS-Modbus-LAN: Modbus Error: [Connection] Failed to connect[ModbusTcpClient(192.168.107.230:502)]
Cloud integration: Unexpected error fetching FoxESS data: Attempted to send an sync request with an AsyncClient instance.

I am very sure that my yaml is correct. also, if I want to connect with my laptop through software to the modbus of the inverter, I also get an error.
my yaml code for the cloud integration is also correct.

Note that my inverter model is apparently a “newer” model.

Can someone help me, did I do something, wrong or is Foxess closing you in, in their cloud services?

Hopping in here. Hope to achieve the same thing but can’t get the inverter on the network.

@vato9394
How did you determine the IP-address and can you ping the device?

I plugged in the ethernet cable, enabled “remote access” through the menu, but could not see any device status.
I have tried a ping tool to ping all devices in the range => Not visible.

Any help would be appreciated, and perhaps I can help you then at the next step