FP2 Set up with Android - what works for me

I struggled mightily getting my FP2 added to my HA and did loads of searching many different posts on different sites to get to a successful outcome so this is my effort to give back to the community and put, hopefully, everything in one place.

Key facts for my success are as follows:

  1. Get the FP2 updated to the latest firmware. I could not get the FP2 to bind to my home’s network (pfSense Router/Fireware with ASUS XT9 Mesh network) out of the box on the firmware that it came with.

  2. In my case I ended up having to use my Android cell phone’s hotspot and a separate tablet to get the FP2 to bind to the cell phone’s hotspot and otherwise get it to the point that I could update the firmware. Once I got the firmware updated, I reset the FP2 and started over to get it on my home’s network.

  3. I turned off broadband data on my cellphone for this part of the operation so only my home’s network was involved. I also made sure that there was nothing blocking access to the internet for the FP2. Initially I let it get a DHCP address so I could grab the FP2’s MAC Address in order to statically assign it an IP address. I continued forward only after I had a static IP address assigned to the FP2 and I was able to ping it from my HA device.

  4. Some folks apparently did not have to do this but in my case I had to turn off all other wi-fi bands on my Asus Mesh network to get the FP2 to “see” the 2.4Ghz SSID. Once the FP2 binds to the network you can turn the other bands back on.

  5. Older posts refer to the HomeKit integration by a different name and you’ll go nuts trying to find it by that name as it doesn’t exist. Unless you want to control HomeKit devices that are connected to a HomeKit controller you do not want to use the HomeKit Bridge, you want the HomeKit Device (it’s current name these days).

  6. Unless you are some sort of networking genius (by my measure anyway) you will need to have the FP2 and HA on the same subnet or the two shall never meet.

  7. Restart the FP2 just before you go to add it to your HA. Some posts say you have to restart it after setting it up to add it to HA, but that is misleading, it will be visible to HA only for a period of time after a fresh boot up. In my case I restarted the FP2 but got busy with something else before trying to find it in HA and it wasn’t to be found until after I restarted the FP2 yet again and then immediately went to add it after I refreshed the HA webpage.

  8. The FP2, once set up and configured with the latest firmware, does NOT need to phone home so it can be completely firewalled off from the internet and it will work just fine.

  9. When using Apple devices to set up the FP2 it is automatically added to the HomeKit Home and you will have to delete it from there before you can add it to the HA integration using the HomeKit Device. Do not mistake this to mean that you have to delete the FP2 from your Aqara App. You do not want to do this because if you ever need to add, modify, or delete a zone or otherwise tweak the FP2’s set up you will currently need to do that from the app as that functionality does not currently exist in the HA integration.

I have four FP2 devices and after I got the first one showing in HA I repeated the process outlined above for the remaining three without difficulties. Turns out that one is faulty, does luminance works, but it does not sense presense. Hopefully I will be able to get it returned.

Derek Seaman has a page for the FP with the title “Home Assistant: Setting up the Aqara FP2 Presence Sensor” that is an excellent source but he only has experience with it and Apple iPhone so hopefully this will round out what he provides for those of us folks that have Android devices.


Thanks for your insight. I have a Samsung S21 phone and could not get the FP2 to communicate with my home internet after it connected to my phone. I put my phone in airplane mode, then turned wifi only on. I restarted the process within the Aqara app to add an accessory and it worked the first time. Thx