Fresh Install? Can't reach hassio.local:8123? No Samba shares?

Im after fresh install too, and as well total rookie :slight_smile: I installed just 3 days ago. If youre asking how long you need to wait till “anything” will be visible at Pi3_IP:8123 - its just couple minutes (maybe even faster). After web page refreshing you should see Home Assistant logo with info about installation in progress (it can take about 20 minutes - something like that).

Image is working, at least it worked in my case. To be sure in your case i would download image again (for Pi3, or Pi2 - depends what hardware you do have) and burn it into sd card using Etcher. You can use other card as well, just to be safe. Errors happen, so… just give a try.

And yea, in my case hassio.local:8123 did not worked as well. Thx Heavens i did “optional” wifi setup with static IP, so i was able to use it instead.
Generally i already noticed a lot of tutorials and docs are… not actual in case of They are for Linux Home Assistant installation, but in some linux comands just does not work, what makes these tutorials and docs generally useless. That makes our life a bit more… challenging.

@imthil This is the blind leading the blind. I remember when I installed with the AIO installer, I had a HDMI cable inserted in the Pi because I had previously had Raspbian installed and was playing around with it. While installing, I saw saw some text scroll by, then a big Home Assistant icon showed up on the page. I sat there waiting for something to happen and it never did. I did not realize that was “headless”. You interact with it through a terminal CLI or the UI or the configuration files. The CLI is pretty limited to viewing logs, updating and restarting. You can’t really get to the web UI until you get the right parameters configured and I could not get the right parameters configured until I could actually get to the configuration files, which required Samba. My original post in this thread was about that. I had a different workgroup name set up in my computer than the default that came with Samba. Once I changed, that, I could see the Samba shares, change the config files and then finally get to the web UI.

1 Like

Hello guys,

I am having a similar problem. Spent the weekend with optional wifi settings, without any setting just connecting to Ethernet and lastly connecting Ethernet with static ip. Nothing has seem to work for me. I am still getting a ‘this page cannot be displayed’ error. also interestingly when I added the static ip, I could ping it like ‘Ping’ and it was responding, so I tried and still no luck. Am I missing something ? do I have to open port 8123 etc ? Will appreciate any help. Thanks.

Hi Guys, I finally have the hassio screen in front of me, phew ! I used Ethernet and then used the app fing to find the ip of my raspberry pi and then used my_ip:8123, then followed what JSCSJSCS has mentioned. It worked

Also I had to re download the image file and then burn it in the sd card. Thanks for the help.

Glad you got it going!

hi all , it seams im on the same nb boat now , some help will be appreciated .
i have installed the sd image ( 3 times now ) , i have the blank screen with the HA big logo , have tryed the ip:8123 , bnut cant get any response from the Raspberry3 ,
im on mac , how to ssh to the raspi, what is the password in first case ?

Hi all
I have a simular problem. I installed Hassio on a RPI.
hassio.local:8123 works from one laptop and from my phone, but I have another computer where it only works with IP-nbr, what is the problem then?
Any ideas?

It might be the other computer has a different “workgroup” name?

I did check that option now, but they are they same. Can anyone explain what happens when I type “hassio.local:8123” in the browser? Where is this translated into a ip nbr?

Same problem here. The tip from @nickosss did the trick. Downloaded the app ‘fing’ on android. Looked for hassio / raspperry PI. There was the IP adres from the Rasperry. Then used that IP & :8123 and entered the site. :slight_smile: Thanks!

Had the same problem; I could only reach it through its IP address but after having a look at my router settings and restarting it, it started working perfectly :smiley:

I had a similar problem this morning: I couldn’t access home assistant from my browser. This has happened despite having access to it yesterday.

I went into mi pi using vssh on my mac and edited the configuration.yaml file. The only thing I did was to remove spaces or tabs which were highlighted by the sublime text editor as purple blocks, all occurring on new lines, at the end of each section of code.

Reloading the home assistant page got it to show.

I hadn’t realised until now how picky HA is regarding spacing!

I finally decided to revisit this today. Must have been a Windows update that stopped SMB v1 support. Add it back in windows components of the programs section of control panel and Samba shares showed up.

Thanks guys, this worked for me.

Go to start menu -> type: workgroup -> change to ‘WORKGROUP’ (if something different) -> find your Raspberry Pi’s IP address -> type that in your browser and add :8123 at the end.

Worked for me!

1 Like

Finaly i solved my connection problem !!!:grinning::grinning::grinning:

Has attempted to connect via (DHCP reservation) and http: //hassio.local: 8123 without success.

Previously I installed Hassbian with DHCP reservation for my Raspberry pi 3 b+ in my router without any problems.
But this obviously did not work for Hassio …

So the solution was to remove the DHCP reservation, run the installation and find the new IP address.Then it works without a problem.:grinning::grinning:

1 Like

can you please help me my problem is 100 percent same as yours

For hassio.local:8123 access, I did following:
1- FIrefox browser :>click Address Bar (left side on round i ). Hassio.local (connection is Not secure).
In More information under connection Details go to permission tabs and Allow where Block.
Hassio.local:8123 is now working.
2- For Samba share I followed this link and did 1,2,3 on my windows 10 PC Link-

Hope this helps.

Wanted to add something that recently happened where I was no longer able to get to hassio.local:8123. My fix can be found here:

I know this is a bit old but I’m struggling with the similar issues. I have the latest Hassio installed with Etcher on RPir3B+. I did the step with seeting up wifi config folder with my-network file. But when I put the SD back in Pi…nothing happenes. can’t access it over hassio.local nor RPi IP directily thru port:8123
Not sure what might be wrong, do I need additional stuff set up on my Router. I haven’t played with it as it’s a lame one given by ISP so not many things can be set up. But not sure if I need to do port forwarding at least. Using Win 10, if that helps