Fresh install on Raspberry Pi 3 b+

Hi Guys,

I am new to home assistant and trying to install Hass os 64bit to my Raspberry Pi 3 b+
Using this method:
The Raspberry is not doing anything besides show this akward red light. No action at all.

I’ve searched the forums and tried different methods of copying the image to the sd-card using Etcher, Win32 Disk Imager, Unpacking with 7zip etc. Nothing works at all.
With a different SD-card i am able to run Raspbian etc. So i don’t think it’s an hardware issue.

Any idea’s what else i can try to get HASSos running?

Your input is already much appreciated as i’ve put a lot of hours in this already trying al different things.

My suggestion is to try installing the 32-bit image. That’s what worked for me.

I have a RPi 3 B+ that previously ran Hassbian successfully. I then tried the HassOS 64-bit image unsuccessfully. So I tried the 32-bit image. That was the ticket.

Hi @Jefe,

Thanks for the suggestion. Trying that right now. Will report back asap

I’ve prepared a new image. Still no luck…

You should have signs of life with the proper hardware. Is the power supply rated for 2.5 amps? Is the microSD-card a Class 10? Does the green LED flash at all?

Powersupply is 3 amp.
Tried 2 different micro sd-cards both class 10
The green light flashes just twice. Very short.
SD-card with raspbian or noobs installer works fine…

Two green flashes means the SD card cannot be read.

Thanks for the input. I’ve read that wiki myself already. So different sd card was my solution. But no luck. Any other idea’s?

All you need to boot-up is the RPi 3B+, power supply cable, ethernet cable, and the proper image on an SD card.

Yes, I know. All things are in place. Only the sd card made with Etcher seems to be causing the issues.

Do you have “eject on success” set in etcher? I’m wondering if preventing any unnecessary interaction from Windows would help. The settings are found through the gear icon in the upper right.

Yes. Its ejecting on succes.

Are you sure there is a network connection?

First boot can take a long time. (differs on every situation) reported is 20 min and 90 minutes. Did you wait that long without touching it? Because it has to have time to prepare stuff before it can run.

Yes double checked yesterday, the power. Swapped that one as well. Checked the ethernet etc.

Hey Frits, Yes i have waited over an hour. I suspect that there would be anything on screen as well?
What would be the normal behaviour of the led lights during first boot? I reckon this would be the same as every other image. Like the flickering green led? It’s give me gives me a green led twice an stops right now.

Have you downloaded the image again? It might be corrupt. Also Etcher will flash from the ZIP file so don’t unzip it first. Also make sure you wait for Etcher to verify the file and say ‘finished’ I’ve done both the 32bit and 64bit successfully. What brand and type SD-Card?

Hi David & others,
Many thanks for the replies and help!
Yes I have downloaded around 7 times :sweat_smile:. An corrupted image was my first thought also.I have downloaded the .img.gz file. Yes i am waitng for “finished” after the verifying status message.
I am using sandisk and samsung. What are the recommended settings for formatting the cards?

I have tried these cards:

I’m using the Samsung EVO.
On Windows you can use the MiniToolPartitionWizard to delete all the partitions on the card and make one partition and apply that.
Etcher doesn’t card about the format as it will format it anyway. Also, make sure Etcher is up-to-data… I had no end of issues with an older version.
You do have to be patient when installing. After you plug the card in and boot the Pi do you see the Pi’s IP address in your router? Can you access the IP_address:8123 in a web browser? That will inform you of progress.

As a last resort you could also put an HDMI cable in the pi itselves and check what it is doing. The green led should flicker every now and then during install. I use SanDisk cards so both SanDisk and Samsung should work. Hope you get to the bottom of this with what David said because I think we’re running out of options.