Fresh installed ZWave 1.4 not working - what do I miss?

Tags: #<Tag:0x00007f3268ab8b90>

Hello everyone,

I installed Home Assistant on a fresh SD card (standard procedure for dummies like myself https://www.home-assistant.io/getting-started/).

My hardware:

Raspberry Pi 3 Model B V1.2
Razberry Z-Wave Plus 5th gen chip ZM5202

I edited /mnt/boot/config.txt to contain both lines:

dtoverlay=uart1
dtoverlay=pi3-disable-bt

In my configuration.yaml:

zwave:
  usb_path: /dev/ttyAMA0

OpenZwave.log says:

2021-01-04 15:05:41.276 Always, OpenZwave Version 1.4.3469 Starting Up
2021-01-04 15:06:29.044 Info, Setting Up Provided Network Key for Secure Communications
2021-01-04 15:06:29.045 Info, mgr,     Added driver for controller /dev/ttyAMA0
2021-01-04 15:06:29.045 Info,   Opening controller /dev/ttyAMA0
2021-01-04 15:06:29.045 Info, Trying to open serial port /dev/ttyAMA0 (attempt 1)
2021-01-04 15:06:29.045 Info, Serial port /dev/ttyAMA0 opened (attempt 1)
2021-01-04 15:06:29.045 Detail, contrlr, Queuing (Command) FUNC_ID_ZW_GET_VERSION: 0x01, 0x03, 0x00, 0x15, 0xe9
2021-01-04 15:06:29.046 Detail, contrlr, Queuing (Command) FUNC_ID_ZW_MEMORY_GET_ID: 0x01, 0x03, 0x00, 0x20, 0xdc
2021-01-04 15:06:29.046 Detail, contrlr, Queuing (Command) FUNC_ID_ZW_GET_CONTROLLER_CAPABILITIES: 0x01, 0x03, 0x00, 0x05, 0xf9
2021-01-04 15:06:29.046 Detail, contrlr, Queuing (Command) FUNC_ID_SERIAL_API_GET_CAPABILITIES: 0x01, 0x03, 0x00, 0x07, 0xfb
2021-01-04 15:06:29.046 Detail, contrlr, Queuing (Command) FUNC_ID_ZW_GET_SUC_NODE_ID: 0x01, 0x03, 0x00, 0x56, 0xaa
2021-01-04 15:06:29.046 Detail,
2021-01-04 15:06:29.046 Info, contrlr, Sending (Command) message (Callback ID=0x00, Expected Reply=0x15) - FUNC_ID_ZW_GET_VERSION: 0x01, 0x03, 0x00, 0x15, 0xe9
2021-01-04 15:06:29.046 Detail, contrlr, Notification: DriverFailed

What is my mistake? What do I miss?

I would really appreciate any hints!!!

HI,

same problem here with the same Hardware.

i tried HO last year and i had the same problems but i could be solved like in this link:

but with this version i didn’t solve the problem.

any ideas?

Thanks
Martin

I have the same issue. Tried

dtoverlay=pi3-disable-bt
enable_uart=1

But I only get DriverFailed, as above.

I’m receiving exact the same error after updating Home Assistant OS from 5.9 to 5.10.
My setup is similar to yours:

  • Raspi 3 Model B+
  • Razberry GPIO Board

Obviously the hassos update has reset my config.txt file! So I attached the SD Card to my windows PC and added (again) the following lines to the end of the file:

# Disable WiFi
dtoverlay=pi3-disable-wifi

# Disable Bluetooth
enable_uart=1
dtoverlay=pi3-disable-bt

# razberry
dtoverlay=pi3-miniuart-bt

But it doesn’t help even after restarting the host.

Please Help!