Frigate HACS Integration (ConfigEntries object has no attribute)

I installed a few updates recently -then my Frigate automations stopped working. No configuration files have been changed for several weeks. Frigate still launches successfully. But, the HACS integration for Frigate is not loading with the following. I appreciate your help!!!

Logger: homeassistant.config_entries
Source: custom_components/frigate/
Integration: Frigate (documentation, issues)
First occurred: 3:40:38 PM (2 occurrences)
Last logged: 3:41:05 PM

Error setting up entry ccab4aaf-frigate:5000 for frigate

Traceback (most recent call last): 
  File "/usr/src/homeassistant/homeassistant/", line 387, in async_setup 
     result = await component.async_setup_entry(hass, self) 
  File "/config/custom_components/frigate/", line 275, in async_setup_entry
     hass.config_entries.async_setup_platforms(entry, PLATFORMS) 

AttributeError: 'ConfigEntries' object has no attribute 'async_setup_platforms'

What version of the integration? Mine is 4.0.0 and working fine.

Where can I find the version #? I’m fairly certain it’s the current release.

It seems to have a problem with one of my configurations. What configuration does it load? There are no issues with the frigate.yml. My guess is that a devices that it’s attempting to integrate with has an issue.

In hacs. Or manifest.json.

1 Like

Hi, I’m running the frigate proxy add-on 1.3 and I see the same error message

What version of the integration do you have?


sigh that is the addon. I asked for the integration

1 Like

Sorry, my bad and my fault. I didn’t remember that I installed the integration manually. thank you. I made the update and now it works

1 Like