Frigate integration not working (Nginx issue?)

I have a Raspberry Pi 4 running on The HA OS. I also have Frigate installed as an Add-on and have installed the Integration on HACS.

When I then add the HA Integration, at the Submit point (connecting to http://ccab4aaf-frigate:5000) I get the error “Failed to connect”. Also I cannot connect via http://x.x.x.x:5000 or https://x.x.x.x:5000 either. However I can connect via the HA sidebar ok.

Separate to the above I have previously installed the NGINX Home Assistant SSL proxy. This was specifically to do with my ESPHome installation (if I recall correctly that mandated an https connection).

I’m suspicous that the https configuration for my HA is what is preventing my Frigate HA Integration from working?

Re. the logs the Frigate logs don’t show anything relating to IP addresses except, i.e. localhost.

The main HA logs do show this

Error fetching information from http://ccab4aaf-frigate:5000/api/stats: Cannot connect to host ccab4aaf-frigate:5000 ssl:default [Name does not resolve]

Any thoughts appreciated.

What do you have in your configuration.yaml under the http heading?

Here you go:

  use_x_forwarded_for: true

What version of the frigate addon are you running? also x.x.x.x:5000 won’t work unless you edit the addon to map port 5000 (it is disabled by default)

Found my (stupid) error…

I was using the default http://ccab4aaf-frigate:5000 in the settings and not http://ccab4aaf-frigate-fa:5000, which is apparently what’s needed when running the “Full Access” version.

@crzynik, thanks for the heads up re. the 5000 direct access option in settings.