Frigate Mobile App Notifications 2.0

Thanks I will take a look.

I forgot to mention you need to set the toggle to true for tv notifications down where the tv settings are. That’s why the group doesn’t work currently.


Thanks, turning on the toggle to True for TV notifications did the trick. I’m just running two automations as suggested to get mobile and TV notifications.

I look forward to your next progress on this. I’m sure you’ll work out images to TV.

Hello everyone I am also interested in the possibility of receiving a message in telegram. I assume that you need to change the notification capability in the frigate_0.11_notification file.yaml is somewhere here:

integration: mobile_app
multiple: false
name: Notification Group

I just had a quick look at telgram and it may be fairly easy to get most functionality working.

What happens if you type the name of your telegram notification group/service in the notification group section? do you at least get the title and message? If there is an error, please provide it.

The blueprint relies on mqtt messages as the trigger.

The MQTT config in frigate.yaml is meant to contain the username and password of your mqtt application (mqtt addon in your case)
You can setup a login for frigate in the config for mqtt

I have image notifications to the tv working in beta 8c.
If you want to do a group that has both android TV and android phones you can notify both but you have to chose which one gets the snapshot using the TV Notifications toggle. Otherwise you can still continue to get snapshots on both by having two separate automations.

I tested my MQTT with the offical frigate automation. With this one everything is perfectly working. With your latest beta I don’t receive anything.

This snippet is the offical way for notifications that is working.

alias: Notify of events
description: ""
  - platform: mqtt
    topic: frigate/events
  - service: notify.mobile_app_iphone_von_XY
      message: A {{trigger.payload_json["after"]["label"]}} was detected.
        image: >-
        tag: "{{trigger.payload_json[\"after\"][\"id\"]}}"
        when: "{{trigger.payload_json[\"after\"][\"start_time\"]|int}}"

Is there some incompatibility with my frigate versions?

Frigate HACS 3.0.0/0.11.1-2eada21
Frigate Add-On 0.11.1

This is my frigate.yaml:

  port: 1883
  client_id: frigate
  topic_prefix: frigate
  user: mqtt-user
  password: mqtt

  enabled: True
  width: 1280
  height: 720
  quality: 8
  mode: objects

#//Sound in recording
    record: -f segment -segment_time 10 -segment_format mp4 -reset_timestamps 1 -strftime 1 -c:v copy -c:a aac

    - person

  enabled: True
  timestamp: True
  height: 480
    default: 10
      person: 15

  enabled: True
  expire_interval: 60
    days: 0
    mode: motion
    pre_capture: 5
    post_capture: 10
      - person
      default: 2
      mode: motion
        person: 2

  width: 640
  height: 480
  fps: 7
  enabled: True

  threshold: 25
  contour_area: 25

  height: 480
  quality: 8

  position: "tl"
  format: "%d/%m/%Y %H:%M:%S"
    red: 255
    green: 255
    blue: 255
  thickness: 2
  effect: solid

        - path: rtsp://admin:[email protected] #//h264Preview_01_sub
            - rtmp
            - record
        - path: rtsp://admin:[email protected]//h264Preview_01_sub
            - detect

Can’t say for sure but do you have the payload from any mqtt messages you can view? maybe from the trace of the frigate example that did work?

i suspect it might be due to use of hyphens in the cam name. if the payload contains the camera name with hyphens that is problematic. I know there are a bunch of historical posts in this thread about using underscores instead of hyphens.

In anticipation of the response being yes, i’ve updated beta 8d with a possible fix for you to try.

is there a bug with notification delay? Its set to 300second, and home assistant says the notification is being triggered constantly via “last triggered” on automation dashboard because it can see cars on the road. The phones are not notified because the cars must be on driveway as it is a zone filter. This is expected behavior… however now when a car crosses driveway, no notification is sent to the phones because the blueprint is forever on cooldown from seeing cars on the road despite road not being on zone filter!


That’s what I would expect as it uses the last triggered time to determine cooldown.

I would remove the cooldown from your car notification, doesn’t sound necessary to me.

Moving the conditionals for zone checking to top level solves the problem. As it will not allow home assistant to trigger the automation, thus preserving a true “last triggered” for cooldown checking.

I see what you are saying. That might be achievable but i can think of a few reason whys it is the way it is.

The automation is designed to run for the duration of a frigate event. In order to track that an event is indeed the same event, it needs to run in a loop and validate future mqtt messages against the stored id. Without looking into it just yet, if we block an event from triggering the automation then if the object later enters the desired zone, frigate wont be creating a new event, just updating the existing one.

A rework of how it reads the mqtt payload might produce a way to do it, we’d have to stop looking for new events and instead trigger based on something else unique perhaps.


Did you try using the newer beta with the hyphens as well or just changed the name in frigate?


firstly thanks for this blueprint.

I’ve been having issues with 3 of my notification automation,

  1. after reading above comments, i thot the issue could be the hypen in my camera names, so I changed the camera names to have no hypen.
  2. even after removing the hypen and recreating the automation from scratch via blue print, still only those 3 cameras don’t trigger notification.
  3. i see this error in the trace Stopped because of unknown reason "null" at December 12, 2022 at 3:43:50 PM (runtime: 0.00 seconds)
  4. i have 3 other location cameras and they work fine with this automation (these 3 cameras never had hypen in their name from begining)
  5. I’ve tried listening to the mqtt topic frigate/events and don’t find any text in this format ‘{{ camera }}/new’ (for working and non working notification cameras)

any help or how to troubleshoot, will be highly appreciated.


This blueprint worked perfectly, until I changed my camera entities.

For example:

Before: camera.voortuin
New name: camera.frigate_voortuin

I did this to find all my frigate entities a bit faster when programming. But after changing this, I didn’t get any notifications anymore. Did I do anything wrong naming it like this?

EDIT: It seems to work when renaming the devices in Frigate itself, not in Home Assistant.

  1. I believe the latest beta might allow hyphens to work (in testing), but otherwise yes, best to use underscores.
  2. It would be great if you could find the details of the error from the full log file at that time
  3. Are all 6 cameras in a single frigate file? if yes, then i suspect the issue is primarily on the home assistant side, either config of the automation, or of the entities
  4. ‘{{ camera }}/new is not in the mqtt payload in that format. it is split in two locations, the first is the name of the camera and the second is the type of message (i dont think you need ot worry about this if other cams are working )

Check your camera entities. If you renamed a camera in frigate from front-cam to front_cam it might now have an entity that is front_cam_2. e.g front_cam_fps_2

The name of the camera from the frigate configuration needs to match the entity in HA.

There are a few things in place to prevent issues such as capitalisation mismatches but the text essentially needs to be the same.

Thanks @SgtBatten , after searching about that error on this thread, i replaced or with else and now it seems to be all working fine on 2022.12.3

Oh you were using the OP blueprint… Gotcha. No worries. Glad you got it working.

1 Like

I’m using the SgtBatten fork of the blueprint but the notification cooldown isn’t working. I get a new notification every few seconds for the same object and it is driving my family crazy. The option to play sound only for the first notification dosn’t prevent the sound from playing on every notification on our iphones either. Anyone else has this problem and have a solution for it?

The cooldown is for different events, and I’m pretty confident is working however, yes someone else has reported the sound problem with iPhones.

I only have android and “alert once” seems to work fine for me so I’m struggling to figure it out.

Can you share the automation config so I can try to look at it logically.

When I get notifications using the 0.10.0 blueprint, they have a snapshot preview built in. However, the notification “view clip” button and tapping the notification itself bring me to the video only if i set an internal home assistant URL. I’m using tailscale to access home assistant, so I set internal the same as external.

If I don’t set an internal URL, I get the popup that says “unable to connect to Home Assistant” with “settings,” “refresh external URL” and “wait” options.

Even with internal URL set (again, same as my external URL), the “snapshot” button on the notification still goes to the “unable to connect” popup. What’s more, even though the “clip” button starts playing the clip, about 3/4 of the way through, the “unable to connect” popup shows up. The video continues to play, though, if I tap “wait.” The popup then comes back again after several seconds.

Any suggestions for fixing this?