Frigate Mobile App Notifications 2.0


firstly thanks for this blueprint.

I’ve been having issues with 3 of my notification automation,

  1. after reading above comments, i thot the issue could be the hypen in my camera names, so I changed the camera names to have no hypen.
  2. even after removing the hypen and recreating the automation from scratch via blue print, still only those 3 cameras don’t trigger notification.
  3. i see this error in the trace Stopped because of unknown reason "null" at December 12, 2022 at 3:43:50 PM (runtime: 0.00 seconds)
  4. i have 3 other location cameras and they work fine with this automation (these 3 cameras never had hypen in their name from begining)
  5. I’ve tried listening to the mqtt topic frigate/events and don’t find any text in this format ‘{{ camera }}/new’ (for working and non working notification cameras)

any help or how to troubleshoot, will be highly appreciated.


This blueprint worked perfectly, until I changed my camera entities.

For example:

Before: camera.voortuin
New name: camera.frigate_voortuin

I did this to find all my frigate entities a bit faster when programming. But after changing this, I didn’t get any notifications anymore. Did I do anything wrong naming it like this?

EDIT: It seems to work when renaming the devices in Frigate itself, not in Home Assistant.

  1. I believe the latest beta might allow hyphens to work (in testing), but otherwise yes, best to use underscores.
  2. It would be great if you could find the details of the error from the full log file at that time
  3. Are all 6 cameras in a single frigate file? if yes, then i suspect the issue is primarily on the home assistant side, either config of the automation, or of the entities
  4. ‘{{ camera }}/new is not in the mqtt payload in that format. it is split in two locations, the first is the name of the camera and the second is the type of message (i dont think you need ot worry about this if other cams are working )

Check your camera entities. If you renamed a camera in frigate from front-cam to front_cam it might now have an entity that is front_cam_2. e.g front_cam_fps_2

The name of the camera from the frigate configuration needs to match the entity in HA.

There are a few things in place to prevent issues such as capitalisation mismatches but the text essentially needs to be the same.

Thanks @SgtBatten , after searching about that error on this thread, i replaced or with else and now it seems to be all working fine on 2022.12.3

Oh you were using the OP blueprint… Gotcha. No worries. Glad you got it working.

1 Like

I’m using the SgtBatten fork of the blueprint but the notification cooldown isn’t working. I get a new notification every few seconds for the same object and it is driving my family crazy. The option to play sound only for the first notification dosn’t prevent the sound from playing on every notification on our iphones either. Anyone else has this problem and have a solution for it?

The cooldown is for different events, and I’m pretty confident is working however, yes someone else has reported the sound problem with iPhones.

I only have android and “alert once” seems to work fine for me so I’m struggling to figure it out.

Can you share the automation config so I can try to look at it logically.

When I get notifications using the 0.10.0 blueprint, they have a snapshot preview built in. However, the notification “view clip” button and tapping the notification itself bring me to the video only if i set an internal home assistant URL. I’m using tailscale to access home assistant, so I set internal the same as external.

If I don’t set an internal URL, I get the popup that says “unable to connect to Home Assistant” with “settings,” “refresh external URL” and “wait” options.

Even with internal URL set (again, same as my external URL), the “snapshot” button on the notification still goes to the “unable to connect” popup. What’s more, even though the “clip” button starts playing the clip, about 3/4 of the way through, the “unable to connect” popup shows up. The video continues to play, though, if I tap “wait.” The popup then comes back again after several seconds.

Any suggestions for fixing this?

Do you mean in the HA mobile app? Or do you mean a baseurl in the automation?

If in the app? Why not set an actual internal IP address?

I’m referring to mobile app. I can’t use an actual local IP because I’m using tailscale.

I’m not familiar with tailscale other than knowing generally what you are referring to.

When you open the clip from the notification it should be opening a url in a browser. If you copy that url and paste it into a new browser window a few minutes later after having the issue playing, does it work?

That might not actually be the default behaviour. I always set a baseurl in the notification. A quick google of your error tells me it has been a known issue with home assistant for a long long time and setting a baseurl in this blueprint should resolve it. I assume you can access home assistant remotely using the tailscale address. type that into the automation.

Tailscale is sort of like a vpn, but you can set it so that it only routes network traffic between the devices you want to connect, rather than all your traffic. Basically, it creates a fake local network where all IP addresses start w/ 100. I put home assistant on that network, and my phone can access the network from anywhere.

I have tried entering a base URL, but that hasn’t solved the issue.

EDIT: I should clarify. I get a different error doing that. I get an error that says: “You can have up to 5 windows.” Not sure what that means.

That’s an annoying error from your mobile browser. I hate that you cant disable multiple windows personally.

You have 5 windows open already and need to close some of them.

If you use chrome or brave etc its usually a “manage windows” option in the overflow menu.

That’s what I thought… so I closed every single chrome tab. And I still get the error. It’s as if home assistant is trying to open chrome more than 5x at once or something, because after I get that toast, I still have no chrome tabs open.

you have no tabs open in the current window. but you have 5 chrome windows open

I’m not sure what you mean by that. I force quit chrome. I shouldn’t have any windows open.

1. In chrome, tap More. Manage windows.
2. Next to the window you want to close, tap More. Close window.
3. To confirm, tap Close window.

Just what i can google. I use brave and it’s very similar. i assume “more” is in the 3 dot overflow menu

1 Like

Wow… I didn’t realize that was a thing in chrome. I’m not even sure how I had that many windows given that they seem inaccessible w/o going to the 3-dot menu. Anyway, that seems to have solved the issue, thank you!!

Yep i hate the function. I literally never want another window to open, but you can’t disable it.