Frigate Mobile App Notifications 2.0

You were trying to open it immediately were you? It might not have existed yet?

Those API endpoints are from the frigate integration not frigate itself, so check that’s up to date.

Hello everyone. I’m needing some help. Im running the latest HAOS, Frigate Proxy addon go2rtc addon, and frigate integration. Im trying to get video and image messages sent through the app as the blueprint above is suppose to help us do. However, I download the blueprint, create the automation, and when I test it to try and run it (even if I try to trigger it by standing in front of the camera) nothing happens. No trigger, no nothing. What is the prequasite if there is any before using this blueprint? There should be no reason not to be able to get this working. My HAOS is on VM via Synology and Frigate is on a separate server. Any help would be appreciated.

The thing I didn’t see mentioned is mqtt. If that is installed, is frigate sending messages to the topic frigate/events?

The automation looks for mqtt messages from frigate.

Edit: One more question, which blueprint are you using?

Sorry, I feel really stupid right now but I just can’t get this blueprint to work:


Is there any error in my config? Can someone help? Should be something obvious.

Hmm, fairly immediate but then it’s not available afterwards either.

Might be a simple answer, the base url in the blueprint is it supposed to point to you HA url or your Frigate url? I have it set to Frigate currently.

Home assistant.


The blueprint in the OP has a bug. Please try one of my updated ones Here.

So guess not too behind, will have to maybe update soon but the current one works great at least.

I am using your one with frigate 0.11.1. I am on nabu casa and cannot get any notification to work.

Here’s my settings - I’d greatly appreciate any tips to get it going (notifications are enabled on my device and i’m all signed in etc - i had this working prior)

I am using nabu casa so it’s odd it’s not working. I assume (hope) i’m missing something obvious

Yeah I can’t get mine working either, using all the same settings as I did on the original blueprint

@Mibix your lists need to be in list format.

use - person not just person. See an example in the pre-amble at the top of the automation config screen.

Same for trigger zone, but that is not currently an issue as you have not enabled it with the toggle above it.

@Joel_DE can you share a snapshot of your trace tree please?

I suspect you need to make your filters (lists) lower case

thanks for your help! much appreciated.

do you mean this?

Yes, but was that triggered manually by you? doesn’t seem to have a trigger at the top. You can scroll left to see a few other historical ones. One of those top two asterix/star things should be coloured like this: image

Derp, got it all working now thanks. Still not used to the GUI editors.

1 Like

I’ll make some improvements so it looks like this where you can select or enter custom values and not worry about the list format, and handle capitals


sorry stepped out for an appointment.

i found one i think was triggered.

looks like it’s filtering on object label so not firing?

ok here’s one i just triggered using the automatoin (not manual)

no notification came through though on my device

so it seems it’s the device i’m using. I can get notifcations fine using node red via HA using this device:

but on the automation I can only select this one:

it seems its’ to do with that. i am trying to use groups and i have my joel_s phone device under there but it’s still not working

EDIT: odd. i got it working. perhaps a restart of ha config helped i’m not sure. but i removed teh group and it’s working fine. i did rename the main person device from Joel Phone to Joels Phone - that coudl have done it?

So the Mobile Device selector only shows individual mobile devices.

If you want to use a group or notify an android tv etc you should use the field directly underneath instead.

Have the blueprint running for some time and it is working great. Only thing is that the snapshot send to the iPhone is to low resolution. I Have an other (bleuprint running also sending an image which is a real snapshot from the camera). How to improve the image which is available after the “click” action. Would it be possible to have it open:

  1. a higher resolution image
  2. or a different snapshot image from media/my_dahua_cam/last_motion.jpg

Thanks, help if I read the prompt properly wouldn’t it! :slight_smile:

1 Like