Frigate Mobile App Notifications 2.0

Hey, I think I see what’s wrong with the images for TV:

It seems that it doesn’t accept a relative URL without the base URL/prefix as the mobile app do. All it is needed is to add then URL prefix then, I guess.

Yes base URL is required for TV notifications. I’ve updated the input descriptions in the beta to make it clearer.

It’s been working well for me for the past 2-3 weeks. how bout you?

My bad, it never worked for me because I forgot to set the base URL. I have set now, so I’ll test.

1 Like

@SgtBatten how do I specify an Android TV to notify? the devices list only shows companion Apps and I’ve tried putting the name of the android TV in the notification group but this doesn’t appear to work?

Using the beta blueprint you enter it in the group section.

My tv was something like notify.android_fire_tv by default so you can enter that or android_fire_tv or android fire tv. All should work. I use the last one with spaces personally.

Then further down set tv notifications to true otherwise the tv won’t get images. You also need a base url set

I’ve just checked and reimported the beta blueprint but there’s no option to set tv notifications to true?
EDIT: ignore me, I’d imported the beta blueprint separately and given it a different name however hass doesn’t seem to be able to cope with the beta version having the same name so was actually returning the nonbeta blueprint regardless of which I’d got selected.

Ahh sorry I didn’t even know you could pull them automatically. I’m just editing the text files

no worries, I’ve just forked the beta version and imported it from my own gist and all is well. (saved me redoing all the existing automation I’ve got from the non-beta version) thanks for the tweaks, saved me the effort of setting these up manually!

Hi, I have now setup Frigate in a separate PC and HA in Raspberry PI. HA integration with frigate/events notification(MQTT) is working when I configure manual automation. I can get the notification on my mobile when there is a detection. However, I have been struggling to use this Frigate Blueprint for the past 2 days and I am still stuck. I have tried to replace the click action with api/events path and replaced the base_url with real url. Also, there is no hypen or underscore on my camera name.
Can anyone please suggest what am I doing wrong here? Should I need to change any specific changes to the blueprint config?

I was using 0.10 version from the tutorials but used the 0.11 beta and it worked straightaway :slight_smile: such a relief.

1 Like

Hi, new to home assistant and trying to get this blueprint to work. I have frigate installed on unraid and working. I have the frigate integration working in home assistant and working. I see my camera devices and when I check the logbook I see events for motion, cat, etc. So I am assuming that the frigate integration is working.

I set up a simple example - I specify only camera name and device to notify - I believe this means any motion. I have tried reinstalling Frigate from scratch. I tried setting up the automations manually but there are so many entities that I couldn’t figure out which ones to use for the trigger.

Happy to post any information that can help diagnose this. Have been working on it for days and looking through different posts but I think my lack of experience with home assistant is getting the better of me. Thanks for any help.

I have read, searched, and googled and cannot figure out how to get notifications to my phone to open in the APP and not in the browser. What might I be missing? The odd thing is sometimes it DOES open in the app. I am using ios fyi.

Thanks in advance

I believe you would need to not have a base url set. And then it should try to open in the app.

But it is also unreliable for playback so it’s much better to open in the browser.

Yep good idea, camera and single mobile device.

No it means any event. Frigate determines if motion meets your criteria (in frigate config) to be an event. If you have zone restrictions or only track certain objects those criteria need to be met. Easy to see if it’s working by checking the frigate events page. If you have events, then things seem good.

Have you setup mqtt in home assistant?

Are you using my version of the blueprint or one from the original post by hunterjm? The OP doest work after frigate 0.10 versions.

Thanks for the feedback. I did not have the proxy add-on loaded. I was also running the original blueprint. So I updated to your blueprint and created two test automations. I do have mqtt broker running and pointing at my mqtt docker in unraid. Frigate is configured to use this. I have no active zones and I do have object detection on each zone and the events when they are detected are showing up nicely in Frigate.

Assuming frigate add-on proxy is needed, I installed the proxy add-on and I keep getting this error:

INFO: Starting NGinx…
nginx: [emerg] host not found in upstream “frigate.local:5000” in /etc/nginx/includes/upstream.conf:2

Frigate is running on my unraid server as a docker and is addressable through an IP - which is what I entered when I setup the frigate integration. frigate.local:5000 doesn’t work and I don’t see any options in frigate add-on proxy to update the address?

However, one of the automations just fired - so something is happening. I think it was the out of date blue print. But I am curious about the add-on issue.


Ignore this, sorry. I was under the impression it was required but i’ve just been reading the docs again and the addon simply gives you sidebar access to frigate within HA. I run frigate on a seperate unraid machine just like you, and have the addon running for access, but i think i was wrong about needing it for this blueprint. Just the integration is required.

So updating the blueprint will definitely be the correct fix.

If you want frigate within HA, you can keep the addon. To set or change the IP address go to settings> addons> frigate NVR proxy and click on configuration at the top.

Thanks - I can’t believe I missed the configuration link at the top. Got that working and it looks like the notifications are working as well. Thanks for your help.

1 Like

Generally works well, but randomly I won’t get notifications, or the notifications are delayed, sometimes by 15 mins. How do I make the alerts instant? I don’t need a link to the video, as I can open the app and look, maybe just a snapshot of what triggered the alert, and the alert itself.

sorry, did u figure it out?

Nope, I didn’t. I think it’s hardcoded in this blueprint and can’t be overridden.

What device are you notifying?