Frigate Mobile App Notifications 2.0

you cant run it manually.

Use debug to work out what is happening.
HA_blueprints/Frigate Camera Notifications/Guide - Debug at main · SgtBatten/HA_blueprints (

Report back with more details

did you start a fresh automation using the blueprint or copy from an old one?

Good call. I used old one. I will make a fresh test and report back.

Freshly generated automations still have the same result, notification sent with links but links resolve to same error…

Site cannot be reached https://xx.xx.xx.xx/api/frigate/notifications/1717821805.236139-jusd6s/frigate_db/clip.mp4

might be temporarily down or it may have moved permanently to a new web address.

From HA I can browse to media/frigate/clips and see clips.

The generated url should be valid on any device for as long as the event exists in frigate.
So something is wrong with your integration perhaps and it is not allowing the API access?

Just checking you are using home assistant as the baseurl right? Not frigate.

It hasn’t changed at all for several versions of frigate including the new beta version.

Yes HA base URL. I have both http and https access. I have tried with IP and FQDN, all yield same error.

Thank you for all your help, I’ve got it working now.

Deleted Frigate server from integrations and added back with IP instead of proxy URL, all working now1

Thanks again!!!

1 Like

Using latest Beta (12.0.4g) as well as current Frigate Beta (0.14.0-beta2). Getting notifications on iWatch and iPhone, but without any attachments (thumbnail) or action buttons on both devices. Clicking on the notification on the phone takes me to the “Open URL?” popup and selecting open will proceed to open the video.

Keep up the great work!

Dump of debug follows:

Executed: June 8, 2024 at 3:03:49 PM
  domain: logbook
  service: log
    name: Frigate Notification
    message: |-
          fps: 5, 
          frigate event id: 1717876928.740874-qgpca2, 
          Objects: Person,
          Sub Labels: 
          camera(formatted): yard(Yard), 
          Base URL:, 
          critical: False, 
          alert once: True, 
          Update Thumbnails: False, 
          Target: Mobile Device
          cooldown: 120s, 
          initial delay: 0s, 
          color: #03a9f4, 
          sound: default, 
          android_auto: False, 
          Group: yard-frigate-notification, 
          Channel: , 
          Sticky: False, 
          Title: , 
          Message: Person detected - Yard,
          Subtitle: , 
          button 1 Text/URL/Icon: View Clip ( , 
          button 2 Text/URL/Icon: View Snapshot ( , 
          button 3 Text/URL/Icon: Silence New Notifications (silence-yard) , 
          icon: mdi:homeassistant
          tv: False, 
          tv_position: center, 
          tv_size: large, 
          tv_duration: 10, 
          tv_transparency: 0%, 
          tv_interrupt: False, 
            zone filter toggle on: False, 
            Multi-Zone toggle on: False, 
            Required zones: [], 
            Entered Zones: ['people_zone1'], 
            Zone Filter TEST: PASS, 
          Required objects TEST: 
            Input: , 
            TEST: PASS
          presence entity (not home):
            TEST:  PASS, 
          disabled times: [], 
          State Filter: 
            state filter toggle on: False, 
            state filter entity: , 
            required states: [], 
            State Filter TEST: PASS,
          Custom Filter: True
  target: {}
running_script: false

I have the same issue, “URLSessionTask failed with error” and no attachment :frowning:

on iphone you have to hold the notification for accessing the action buttons.

I’ve been getting occasional phantom notifications from this blueprint without an event image attached. It’s not the automations fault and this might be obvious (I’ve not scrolled this whole thread) but the /events topic isn’t a 1:1 mapping to a Frigate event, i.e. Frigate might post to events saying a person was detected but then decide it’s not accurate enough to become an event in Frigate (and is likely a false positive) so in turn there’s no image to attach to the notification.

It sounds like in the latest Frigate beta (0.14+) the reviews topic is a 1:1 mapping. I’ve set that as the MQTT topic in my automation but it doesn’t seem to work - the notification isn’t sent at all, I’m guessing as the mqtt payloads are different and something is missing?

I’d say most people using this blueprint are only actually interested in getting a notification when there’s also an associated Frigate event (and snapshot) so it might be worth that becoming the default topic in the blueprint - if the user has the beta of Frigate installed that is? Otherwise what good is a notification without any associated image/clip data!

Thanks to NickM-27 for helping identify this: [Support]: Phantom detection "events" · blakeblackshear/frigate · Discussion #11847 · GitHub

You have to use the 0.14 blueprint discussed above

I did check the beta blueprint and I’m sure I saw the default mqtt topic was the same as the stable version? frigate/events and NOT the review one, as long as there’s not a 1:1 mapping the issue will persist unless there’s some form of “detected for” time limit (in my latest problem notification person was only detected for 0.3s).

Not the main branch beta. Different frigate 0.14 branch.

Follow this pull request and copy the changed file into home assistant manually. Frigate 0.14 by SgtBatten · Pull Request #216 · SgtBatten/HA_blueprints · GitHub


Perfect, I’ll get that setup tomorrow thanks!

Thanks a lot for this BluePrint.
I have a problem with iOS notification, i receive the notification on my phone but without image and without button, if i click on the notification i see the snapshot take by the cam.
More strange : on my Apple Watch, the notification appear and i saw the image and button ! but button didn’t work.
Do you know why ? Have you a solution ?
(Sorry for my english, i’m french user)
Thanks a lot

Could we get an option to set Title headings for notifications please?

Currently, we can only set subheadings, which makes it look too cluttered. I want to be able to remove ‘Home Assistant’ title with my own like other blueprints.


Did you ever get this to resize? I’m seeing the same issue on my Pixel 7. Clicking on View Snapshot reveals a black screen with scroll bars until you scroll down to see the large snapshot. Not even pinch to zoom works . Thoughts?

whats the key that is needed/ you want?

we already have title, message and subtitle

whats the format of the url that it opens?