Frigate NVR "Failed to Connect" Error - Installing From HACS

So, I’m another person trying to get Frigate to run in Home Assistant. I seem to have have run into a problem similar to others where I get a “Failed to Connect” message when installing the integration. I’ve been doing a bit of searching and have not been able to find a solution so far. Some of the people give up on getting it to work, others get it to work but have problems different than mine. So I will add my voice to others in asking for help figuring out why I’m getting the error message and what I can do to fix it. I’m hoping the solution will be simple like leaving out a step or something. . . .

I’m running Home Assistant OS on a Dell MFFPC

Here is my install sequence:

09 Frigate YAML

I have restarted Home Assistant several times through the Developer Tools page during the install.

Do I also need to do any port forwarding in my router like I had to to install Home Assistant? I tried adding Port 5000 and 1935, it didn’t help but maybe I didn’t do that correctly.

Thanks for anyones help.

1 Like

You don’t show any steps of installing the frigate addon, have you done that?

Maybe I didn’t. I’ve done what a couple of different tutorials have told me to do. From what little I understand when I have done the above steps Frigate should be ready to setup. If thats not the case then I guess Frigate is not installed. . . .

I found a video tutorial that went over some of the things that I missed. So I seem to have Frigate installed now.

The camera window is all green.

I am also getting the “Failed to Connect” error message as well.

Just an update. I did manage to get the camera working, I had to adjust my config file (camera resolution). I still don’t know about the “Add Integration” error message I’m getting.

The addon says its hostname in its info page. You can see it in one of your screenshots:

You’re trying to connect to it by using the url http://ccab4aaf-frigate:5000. That won’t work. ccab4aaf-frigate isn’t the hostname of that addon, ccab4aaf-frigate-fa is. You have to use http://ccab4aaf-frigate-fa:5000 in the integration config.

No clue why the instructions in the pop-up to say to use a different URL. Maybe the addon changed its slug (which changes its hostname), maybe you’re using a different addon then the integration author expected, maybe its just a bug in the integration. But if you use the correct URL does it work?

EDIT: Just to be clear, I have never used Frigate (addon or integration). So there may be other problems, idk. But I do know addons and can clearly see the URL is wrong so I can help with at least that much.

1 Like

Wow!! You have a sharp eye! I didn’t even notice that but I’m not too familiar with Home Assistant either. You are correct, it was giving me an incorrect URL. I copied what was there and added (:5000) “ccab4aaf-frigate-fa:5000” and it worked finally.

15 Frigate Integration Sucess

I tried typing that address into my browser but it didn’t work:

http://ccab4aaf-frigate-fa:5000 nor https://ccab4aaf-frigate-fa:5000

I don’t know if that is supposed to work, I read somewhere that if everything is correct that I should be able to access that through a browser using that address. Maybe I’m mixing it up with something else, I’ve read so many different things I can’t be sure.

Thank you very much for your help. I would have been working at this forever.

No that url won’t work from your browser. All addons are actually just docker containers, they run on the same docker network. That hostname resolves only within that docker network. So HA can use it to talk to the addon and other addons can use it to talk to each other. But random devices on your LAN can’t see those containers and use that hostname.

On the config page for the frigate addon, is there a section below that lists ports? And is 5000 one of the ones listed? If so you can list a port in the box next to it (5000 again or something else). This maps that port on the container to a port on the host machine. Then you can go to http://<ha hostname>:5000 and get to it’s UI. “Ha hostname” being whatever is in your url bar at the top before the port of when looking at HA.

If there’s no network/ports section in the addons config page then you can only get to the UI via ingress (the frigate option in the nav bar on the left like you showed above).

There is this page that has ports

If I turn the switch on to show disabled ports I see 5000 and 1935. So you are saying that I should type 5000 on the line for 5000? I’ll give it a try.


1 Like

Yes exactly. If you want it exposed on the host so you can access it and it’s streams directly without going through ha. If you’re fine just using it from within HA then that’s not necessary

Great. Thank you for the help. I tried it and I can access it from my browser at port 5000. If I find I don’t need it then I’ll disable it again.

Thank a lot! This really help. Please note that the url is now different and you have to copy the hostname in the addon.
Do not use the one in the Frigate Docs at the moment.