Frigate+Stream camera entity pulls up stale "real-time" stream somehow (days old!)

I stood up a Frigate instance to monitor my cameras. The cameras appear on Home Assistant using the stream: directive. I’ve noticed periodically that I’ll click on a stream and it will start playing back an old/stale stream. I don’t know where it gets that from but it must be stuck in cache because usually it’s dramatic… like during the day, it shows me a stream from nighttime… complete with audio!!

It is happening again right now and it’s showing me a stream from 7/4 even though it’s 7/6! I restarted the Frigate docker instance and the problem persists so I’m wondering if the fault is on the Home Assistant “stream” side. The problem right now is only affecting two of my seven cameras but they’re both streaming video from 7/4. I tried -F5 (cacheless) refresh and the problem persists. I’ve tried enabling and disabling the “Preload Stream” option and it doesn’t seem to make a difference.

Anyone else experience this or know how to resolve it for good?


More data points:

  • This problem affects both the mobile application and the web page app through a Chrome browser.
  • I can completely recreate the Frigate container behind the scenes and the old stale stream persists.
  • If I restart Home Assistant, the camera stream functionality comes back.

I’ve updated to Frigate RC6 and this problem persists. I’ve run it for about two days and I have one camera which shows a stale stream, the others appear to be working. The affected camera just plays the same 4-5 second clip over and over again in HA. The camera appears to be working fine from Frigate’s web interface.