Fritz!Box Crashed Haas?

I have been trying to get my fritz!box talking to HA.

I had been trying to do this using my all-in-one install on a RPi2B but since I just found out that the all-in-one is now depreciated, I bit the bullet and got a shiny new RPi3B since I had lost my Pi for ‘fiddling around’.

Anyway, the installation of was actually BRILLIANT and once I added in teh configurator, I was able to edit all my YAML files as I had them before, installed LetsEncrypt and could access everything perfectly as before with a minor tweak or 2 due to the files not being in the exact same folders.

I did have an issue with the configurator but I’ll put that in another thread.

Anyway, I can’t get my fritz!box to talk with HA and if the below lines are uncommented, HA won’t start.

# FritzBox
  - platform: fritzbox_netmonitor
    host: !secret my_fritz_host

Any ideas?

Not sure wether you solved this problem already or not, but I ran in to the same (or a similar) issue on my pi2. In the end I “fixed” it by just waiting longer… Took about a half an hour for the netmonitor service to install after which HomeAssistant booted normally. Reboots are fast now as well.

If you try again, try setting the logging in debug mode so you can see what’s going on. During the first boot with netmonitor enabled it should say something like “attempting to install netmonitor service”. If that’s the case, just let it be for half an hour or more.

Thanks. I might give it another try.

I had a similar problem, but with the Fritz! device tracker.

The reason was, that “lxml” was not installed properly within the HA venv. Maybe it is woth to check if all dependencies are installed correctly:

“It might be necessary to install additional packages: $ sudo apt-get install libxslt-dev libxml2-dev python3-lxml If you are working with the All-in-One installation, you may also need to execute also within your virtual environment the command pip install lxml; be patient this will take a while.”


Thanks. It seemed to be installed correctly. I’ve now switched to Hassio and it’s not working in there either. Not worried about it. Would be nice to get it to work.