FRITZ!Box Tools integration stopped working / can´t login

Hi ya´ll.

I´m using HA via the docker image and all was working fine, until I had to mess with my Fritzbox a week ago.

I got everything back how it was, but HA won´t accept the login credentials for “FRITZ!Box Tools” anymore.
I´ve already tried to create new creds / delete the integration / etc.

My actual host is 192.168.179.1, but everytime I try to change it, it jumps back to 192.168.178.1
Everytime I try to integrate it I get a “connection failed”, after which it jumps back to:

host: 192.168.178.1
port: 49000

I´ve already setup the configuration.yml:

fritzbox:
  devices:
    - host: 192.168.179.1
      username: !secret fritzbox_user
      password: !secret fritzbox_password

I´ve already scoured through many forums, but nothing seems to work so far.

There was an issue with this on 2022.4.0, which I think has been fixed in 2022.4.1 .

If you updated from 2022.3.8 (or any version that isn’t 2022.4.0) to 2022.4.1 it should just work now, but if you went from 2022.4.0 to 2022.4.1 then you may need to remove and reinstall/rediscover the integration again.

I had this problem when I did the update from 2022.3 to 2022.4.0. The SmartHome integration wouldn’t take username/pwd at all, and then a little while later the tools one failed too. I got the latter working using the admin credentials (the fritz#### user you can find in the user list on your Fritzbox with the password on the label underneath the box, at least if you haven’t changed it).

Try that username, optionally with removing and rediscovering the integrations if required.

I got the tools integration working that way. Not sure if the SmartHome one is OK or not now, as I don’t use any FB smart things so I just ignored it.

Also if memory serves (not always reliably these days), I don’t think the configuration entry is needed any more. I think it auto-discovers these days.

Updating to 2022.4.2 fixed the problem with the integration not working, but now I´m getting a different error:

Setup erneut versuchen:
UPnPError: errorCode: 401 errorDescription: Invalid Action

I´ve already checked in my FB that UPnP and TR-064 are turned on and I´ve also tried to delete / integrate it a couple of times.

Got any suggestions?

Web 401 errors are normally lack of authorisation.

So I’d double-check the username and password, and that the user account used is a suitable one (the admin account would certainly fit that bill).

Beyond that, not really.

I´ve tried it with a dedicated homeassistant user and with the admin account, but getting the same error.
I´ve read somewhere that there´s supposed to be a known_devices.yml, but I couldn´t find it anywhere - maybe that´s got something to do with it?

AVM FRITZ!Box Call Monitor and AVM FRITZ!SmartHome integrations don´t bring up any errors so I´m out of ideas.

known_devices.yaml is the old way of device tracking, using the older integration.

That one is depreciated and was removed quite a while ago.

I’m also out of ideas, maybe @chemelli can give some thoughts on this one?

Alright, I´ve got it working again.

Final solution was a good ol’ restart of the FritzBox itself.

Thanks again for your help! :slight_smile: