Fritzbox integration not working

Hello guys,

i have a problem with the fritzbox integration. I´ve set it up like in the documentation

   - host:
      username: user
      password: pw

but when i rebbot it says the following components and platforms could not be set up: fritzbox. Please check your config.

I´ve tried it with and also the ip adress but it doesnt work. What can i do ? I just want to control my thermostat with home assistant.

Does really noone have an answer for me ?

Have you enalbed the smarthome access for your user?


Your config looks wrong. username and password should start at the same place as host. Like this:

  - host:
    username: user
    password: pw

Indentation is important in YAML.

Hello guys, i have a issue with the setup as well. I tired it already several times with different integrations. I get no errors but no new devices as well. Do i forget something (Ím a newbie).Here my current setup:

Pi 2 with HassOS 2.12
Fritzbox 7590 OS 7.10

I have added the following to my FB:


  • platform: fritzdect
    username: xxx
    password: xxx

BTW i also tried the „fritzbox“ integration :wink: Same issue… I try to setup a HAN FUN sensor and power switch.

Please help!

I have a similar problem. fritzbox integration suddenly not working anymore. It worked some days but now i got the message after restart. This happened before but did also somehow go away (maybe by update…). the Error message is:

Invalid config

The following integrations and platforms could not be set up:

* fritzbox

Please check your config.

Restart of Fritzbox and hassio did not help

    - host:
      username: xxx
      password: xxx

HassOS 3.12
Supervisor version 209
Everything (addons) ist uptodate
Fritzbox 7590 Version 7.12
Home Assistant 0.106.5

Had this issue after upgrading to 0.106 - for me it works by using the routers ip address instead of as hostname

ip-adr instead of “” did not help, same issue with Version 106.6, also tried different fritzbox users

from today is back working again. no update, no restart, no idea ???

and now not working anymore, no changes?

I have exactly the same issue.

any idea what changed for you?

Running Home Assistant in Docker

no solution yet. In case of failure fritzbox reports wrong password “Anmeldung des Benutzers xxx an der FRITZ!Box-Benutzeroberfläche von IP-Adresse xxx gescheitert (falsches Kennwort)”

added a new user to fritzbox- with this user it is working now. Lets find out how long.

I have found an issue: Homeassistant uses old credentials after restart/reboot. In my case it tries to login with a old username to fritzbox. configuration.yaml has the correct username but they are not used to log in. Is there a cache ?

for me enabling “Anmeldung mit FRITZ!Box-Benutzernamen und Kennwort” fixed the issue permanently for me. Was working without that option enabled before.

in a picture:

This have to be activated!
the second, deactivated, choice in this picture is the default (“Anmeldung mit dem FRITZ!Box-Kennwort”) in which you do not need a username by login, only a password.
NOW you need the username and password by login on the Fritz!Box UI (!!!)
which you create in the “Benutzer”-Tab

The newest FritzOS Update 7.25 breaks the integration.

Update: Delete and new integration solve the problem

Show in your FitzOS under System -> Users. Here is a New User “fritzXXXX” change this name to “admin” and change from this user the password to your Router Password. Then restart homeassistant.

1 Like

i switched from FritzBox 7560 to 7590.
A user is configured in the Fritz box. I’ve tested different users but this cannot be the fault. There is no login error in the fritzBox log.
Now i get an login authorization error by the integration ‘AVM FRITZ!Box: FRITZ!Box 7590
AVM FRITZ!SmartHome’.
On the contrary: The Fritz!Box Tools integration is working fine: image
Home Assistant Core 2022.6.2
Home Assistant Supervisor 2022.05.3
Home Assistant OS 8.1
FritzOS 07.29

Has anybody a hint for me?