Fritzdect login fails after a while

Tags: #<Tag:0x00007f7c60054b08>

Hi guys,

I moved yesterday from fhem to home assistant and I really like the UI and stuff. I was successful in setting up and adding my hardware to HA (mostly HUE, Fritzbox, Bravia and an AVR).

On the Fritzbox part, I’m using components:

  • fritzdect
  • fritz
  • fritzbox_callmonitor
  • fritzbox_netmonitor

All components are using the same credentials (username/password) and after my first setup yesterday, all where working without any issues. Today in the morning, I noticed that for some reason, fritzdect was no longer able to login - although nothing was changed on my fritzbox and in the configurations over the night.

The other components are still working fine - again: using the same credentials and host. Is this some kind of a bug?

Not using any Fritz-components, but as a general question: did you have a look at the HASS logs? It usually gives some hints on what the problem might be.

the log just says that login failed. Again: nothing changed and other fritz services are still running with the same credentials. It seems, like after a while, the password was corrupted in the hass database or something for fritzdect only.

I have the same problem. After some time and a restart of Home Assistant it fails to login. The configuration didn’t change. An additional restart does not help, I have to comment out the switch section for the fritzdect platform, do a restart, then remove the # and do another restart. Then it works again for a while.

Home Assistant is version 0.54.0. My Fritzbox is a 7390 with FritzOS 6.83.

This is the error message:

2017-10-05 09:13:18 ERROR (Thread-9) [homeassistant.components.switch.fritzdect] Login to Fritz!Box failed

The same error for me here:
Using Fritz Router type 7490, OS 06.93

Working components:

  • netmonitor
  • callmonitor

Running components on latest version 0.63.2 of HA (hasbian basis)

The only error is doing the fritzdect component telling me
ERROR (Thread-18) [homeassistant.components.switch.fritzdect] Login to Fritz!Box failed
INFO (MainThread) [homeassistant.core] Bus:Handling <Event system_log_event[L]: message=Login to Fritz!Box failed, source=components/switch/fritzdect.py, exception=, level=ERROR, timestamp=1518786891.78179>

I added a user to my Router, having privileges on “smart home” objects, as this failed i added complete acess for testing, but error stays the same.

Anyone any ideas?

Thanks in advance
/Ralf

Now homeassistant.components.switch.fritzdect is spamming my logfile every 5-10 seconds:

ERROR (SyncWorker_19) [homeassistant.components.switch.fritzdect] Fritz!Box query failed, triggering relogin

which is strage since everything is working related to fritzdect.

Is there a solution?