Fronius Integration Connection Failed

Hello,
I have a newly installed Fronius Symo Gen 24 Plus with Power meter and trying to connect it to homeassistant using the fronius integration.
I got stuck at the very first step when the integration is requesting for the IP Adress. Have been looking around for quite a while now, but could not find any topic related to this issue.
I have tried via Hostname, and IP adress (http://192.168.x.x and also 192.168.x.x), but always getting the error message “Failed to connect”.
I can access the Inverters web page when entering the IP adress in the web browser.
Any Idea of how I can make progress in this topic? Do I need to make any additional configurations on the Inverter side? Thanks in advance.

Hi :wave:!

Look for “SolarAPI” to activate in your inverters web interface. On my system this can’t be deactivated, but I don’t have Gen24 so it may be the case for yours.

Other than that, are you 100% sure the IP address can be accessed from your Home Assistant device (not from your computer)?

If yes, then proceed to look at the logs after a failed connection attempt: Open your Home Assistant instance and show your Home Assistant logs. you may even set log-level to debug:

logger:
  default: info
  logs:
    homeassistant.components.fronius: debug
    pyfronius: debug

Thanks for your reply.
Will check “SolarAPI” next week. Will need to get customer PW from my installer. (Assuming it is active as I have acces via the solar.web App, but will check that.)

No, I am not 100% sure my HA device (Raspberry PI) can access the IP. How can I check?
Its the same network and subnet. Both connected via LAN to my Router.
Have checked with a Button Card, and that is opening the web interface in my PC Browser. Possibly not the right way to check…

Logger provides the following:

2022-03-12 10:59:55 DEBUG (MainThread) [pyfronius] using highest supported API version API_VERSION.V0
2022-03-12 10:59:55 DEBUG (MainThread) [pyfronius] Get current logger info data for GetLoggerInfo.cgi
2022-03-12 10:59:55 DEBUG (MainThread) [homeassistant.components.fronius.config_flow] Device type current logger info not supported by the fronius device
2022-03-12 10:59:55 DEBUG (MainThread) [pyfronius] Get inverter info data for GetInverterInfo.cgi
2022-03-12 10:59:55 DEBUG (MainThread) [homeassistant.components.fronius.config_flow] Device type inverter info not supported by the fronius device

Is that indicating a deactivated API?

Just to be clear: I don’t even know if that is possible. You may look it up in the inverters manual.
Nevertheless, it should use Api V1 so something is wrong. What firmware version is the inverter running on?

I made it:
Rootcause was indeed a deactivated Solar API. Thanks farmio for pointing me in that direction.

So for all facing the same issue: (Valid at least for Fronius Symo Gen24):

  • Go to the Inverters Web Interface / Communication / Solar API
  • Activate “Communication via Solar API”

There should be a hint in the documentation for Prerequisites. Will try to request a edit.

1 Like

Hello everyone,

I have activated the Solar API and set a static IP for the inverter (Symo Gen24 Plus). However when entering the IP for connection, HA just spins for a few minutes and then tells me that an unknown error occurred.

The inverter sits in 192.168.1.xx and the Pi on which HA runs sits in 192.168.20.xx. I’ve set up all firewall rules properly so the Pi is allowed to get connected to all networks and this works (except for Sonos devices but that’s on another page).

As I am a complete rookie I have no clue what to provide in order to give more information for help. When looking at the log file I can’t see any messages related to the Fronius integration.

Maybe anyone has an idea what to do for troubleshooting?

Thanks in advance.

Hi :wave:!

Maybe just try to curl http://10.1.2.5/solar_api/GetAPIVersion.cgi from your raspi (replace the IP) to see if you get any result.
Other than that set the log level of pyfronius and homeassistant.components.fronius to debug and see if it yields any usable information Logger - Home Assistant

If I had to guess: its an overcomplicated network issue :upside_down_face:

Hi farmio,

Thanks for your reply. Maybe a very stupid question, but should I execute the curl command in the HA SSH terminal or directly from the Pi? I have the HA OS installed and not as a docker on the Pi.

I will put the Pi in the same VLAN as the inverter to see if that works when I’m back from work. :slightly_smiling_face:

I don’t know if there is any difference - but I have no experience with HA OS.

Did you set the inverter to power off at night? It would also not be reachable then.

Good evening.

What shall I say, stupid mistake. :man_facepalming:

Even though I have checked the firewall settings three time I have overlooked a typo. Now it is working perfectly.

Big sorry!

Thanks for your help anyway, farmio.

1 Like