Fronius Symo 5.0-3 M Inverter Integration

Have been trying for a couple of days now to connect my Fronius Symo 5.0-3 M Inverter. This inverter is about 2 years old and I can easily find the Fronius Integration through HA, but I cannot seem to connect it via the IP Address. I have set it up in the Solar.Web interface with a Static IP (192.168.1.XX) and tried to use that but it just keeps spinning and timing out in HA saying ‘failed to connect’. I have also tried activating the Wifi Access Point and then using the 192.168.250.XXX IP of the Wifi Point and that does not work either. I have read over dozens of posts across a bunch of sites and now at a loss in working out what the issue is. A lot of people talk about activating SolarAPI, but there is no option for this in the inverters web interface. Has anyone managed to connect/integrate a Symo 5.0-3 M to HA using the Fronius integration and IP address. Would love to know what settings you have in the Solar.Web interface and HA. appreciate any assistance. Thanks all.

I dont have an API setting either on my Fronius Symo 15.0-3-M - but integration just works for me… do you have your unit connected to LAN or WIFI ? and if so, which settings do you have on your unit…

I dont have anything specially configured on it except a static IP connected via LAN. - …

Yep, mine is over Wifi. I don’t see a physical LAN / ethernet connection point on the exterior of the inverter though. Where is the connection?

Do you have a datamanager installed?

This should be under the grey/red cover that is bolted with 2 front bolts on the front sides… given you have wireless, that should be there as well…

Just a quick question though… are you sure the unit is on YOUR wifi, and not in AP mode (where you connect to the wifi SSID broadcasted by the unit itself, rather than the unit joining your wifi SSID…

Yes, thanks. The datamanager is behind the panel. Yes, the unit is on my Wifi but on the WLAN connection with the 192.168.1.xx IP, whereas all my other wifi connected devices such as phones, computers etc have an IP of 192.168.50.XX. It is not connected on through the Units WAP with the IP of 195.168.250.XXX.

Just surprised this doesn’t work on wireless.

Thanks again

When HA device is on a different network / subnet than the inverter you would need to set up forwarding rules in your firewall. That seems to be a basic networking issue.