Front End Refresh Issues

I am having some front end refresh issues with some zwave lights. Since release 33 if I turn off a light the icon remains lit, however the light responds to the command and turns off. The only way I can get it to refresh is to turn it off and on again. I have re-installed HA on a secondary box with the same controller and the issues continues to occur post release 33. If I run the same configuration on release to 32.4 I do not experience the issue. I have tried zwave resets and heals and it does not correct the the issue. If I turn them back and on again the icon status will change. Switches do not experince the same issue.

Image shown below:


I’ve noticed this same issue with my install. My two zwave light entities will get stuck on in HASS, even though the light itself is off. Sometimes toggling it on/off in the frontend will update its status until the next time the light switch is physically turned on.

Doesn’t seem to be a frontend caching issue, as it also shows in the log/history graph as being on for the entire time.

I have the same behavior. If I toggle on then off then the status seems to be in sync. Until the next time. What type of lights are they?

Mine are the GE/Jasco Zwave dimmers

Mine are a mix of dragon Tech and homeseer