Frontend crashed after API call

I’ve just started using the Python API.

I (remotely) called Home Assistant:
import homeassistant.remote as remote api = remote.API('<URL>', '<password>) remote.validate_api(api) remote.set_state(api, 'group.stairs', new_state=STATE_ON)

As you can see, I set the state of a group and not a switch.

I then went to the front end to see if it went well.
The front end is just a blank screen and the log says:
2018-07-30 01:43:25 ERROR (MainThread) [frontend.js.latest.201807040] <URL>/frontend_latest/app-4292f66004397bd401a51afce535490e.js:2:12634 Uncaught TypeError: Cannot read property 'forEach' of undefined

I think the two are related, because everything worked a few minutes before I ran the API call.

Anyone has any idea about what is going on?

We probably will retire remote API in the future. Anyway, could you please provide the HA version you are running, your frontend version looks like not the latest.

Thanks for the reply! Since I can’t access the front end, how do I find out the HA version? Probably should have said, but I’m running

If the remote API will be deprecated, what is the preferred method to change states in HA remotely from Python?