Frontend dev environment setup problems - node-zopfli is dead? (dev dependency)

Can’t setup dev environment for frontend.
Always fails during yarn installation on:

error /mnt/c/Users/Yosi/dev/home-assistant-polymer/node_modules/node-zopfli: Command failed.
Exit code: 1
Command: node-pre-gyp install --fallback-to-build
Directory: /mnt/c/Users/Yosi/dev/home-assistant-polymer/node_modules/node-zopfli
node-pre-gyp info it worked if it ends with ok
node-pre-gyp info using [email protected]
node-pre-gyp info using [email protected] | linux | x64
node-pre-gyp info check checked for “/mnt/c/Users/Yosi/dev/home-assistant-polymer/node_modules/node-zopfli/lib/binding/node-v57-linux-x64/zopfli.node” (not found)
node-pre-gyp http GET
node-pre-gyp http 403
node-pre-gyp ERR! Tried to download(403):
node-pre-gyp ERR! Pre-built binaries not found for [email protected] and [email protected] (node-v57 ABI, glibc) (falling back to source compile with node-gyp)
node-pre-gyp http 403 status code downloading tarball

Seems that node-zopfli is dead. They have stopped maintaining it.
What can I do to workaround?

@balloob would appreciate your help. Thanks!

To unblock yourself now: uninstall node zopfli (with yarn remove). You don’t need it unless you’re making a production build.

It’s used in a gulp step to compress our assets. We should migrate that to use a Webpack plugin. A pull request is welcome.

Thanks. The problem is I can’t get past yarn install since it can’t find it. So I have nothing to remove… Can I somehow remove it from the scripts under home-assistant-polymer ? Which files should I edit to do this?

Ehr. Just run yarn remove node-zopfli

I get: “error This module isn’t specified in a manifest.”.

Nothing helps…
I’m not sure if anyone has recently managed to setup a frontend dev environment… I’d love to know how or download an image that works.
Feeling lost & frustrated. :frowning:

Is there a way I could take the open dev files and put on a duplicate prod environment to play around with the markup, etc? That’s all I want to do and later create pull requests on some features I think are needed.

Thanks for trying @balloob

I removed all zopfli references from all files (except JS) and got past yarn installation. But now running the script/develop fails since there’s no gulp-zopfli…

catch 22

@andrey - maybe you can undo what you did in “switch to Zopfli compression (#744)”? I’m not yet familiar with the code and don’t want to kill anything.

@balloob - any other ideas I should try?

Thanks Guys

This has now been fixed in the main branch. Thanks everyone.