Frontend shows old version number after (successful?) upgrade

I’m running Home Assistant Core. When I upgrade via pip3 install --upgrade homeassistant it reports that homeassistant-2021.1.5 was successfully installed. However, the frontend Info page shows version 2021.1.1. As a result, I can’t log in remotely via Nabu Casa, and I’m getting warnings about running an unsecure version.

Here’s what I’ve tried (with rebooting the server between each step)

  • Updating the raspberry pi generally via sudo apt update, sudo apt full-upgrade
  • Uninstalling HACS
  • Deleting everything in my configuration.yaml except default_config:
  • running pip3 install --force-reinstall homeassistant

The only interesting thing in the log is this message:

2021-01-24 19:01:33 WARNING (MainThread) [homeassistant.bootstrap] Support for the running Python version 3.7.3 is deprecated and will be removed in the first release after December 7, 2020. Please upgrade Python to 3.8.0 or higher.

But it seems unlikely to be the issue?

I did some further sleuthing. .HA_VERSION file has 2020.1.1 in it, I tried deleting that file and rebooting and it creates the same file with the same contents on reboot. I’m not sure why it’s getting set to that version.

Should I just give up on running home assistant in a virtual environment and switch to Docker? That seems to be what people are doing? It just seemed like a lot of configuration and I had this thing basically running how I wanted it…

Hi, same issue here, I can’t upgrade core from 2021.1.1.

I manually pulled the docker images but seems to be using the latest tag instead of stable…

Any workaround?