Frustrated by Nabu Casa and looking for ideas

I just went through a repeat of a problem I’ve had in the past.

Recntly I restarted the HA core because of an unrelated issue. And the next time I tried to access it remotely, the phone app told me it couldn’t connect to Nabu Casa. Retries didn’t work, trying to connect through the Nabu Casa web site didn’t work. When I got home I checked my HA Configuration/Cloud status and it cheerfully told me it’s connected to Nabu Casa, and that “Auto Reconnect” is on. But it still wasn’t reachable through Nabu Casa.

The thing that finally worked was explicitly logging off of Nabu Casa, from HA, and logging in again. HA then showed me “fetching subscription” forever, but was reachable again.

I think this implies that if I were traveling and my house had a power loss, I’d likely be unable to reach my HA instance. And if I can’t make it more reliable than this, it’s not a good home automation solution.

I can’t believe HA still lacks this basic element of robustness. Or is it “just me”?

I’m out of ideas.

The only thing, I can tell you, that in one year of NC subscription I never experienced such problem.
I do access my HA install with NC on daily basis, several times a day, by PC’s on my work, by the Android app, even with HassIQ on my Garmin watch. Even at home most of the time, just because it is bookmarked in my browser.
The only thing I ever notice is one missed connection per 3 weeks, by clicking refresh it just goes on.

There must be something with your own setup…

1 Like

I’ve accessed remotely many times. The problem seems to be that it didn’t restore the connection after the restart. “Auto Reconnect” not only didn’t work, it lied about it.

As I’m building the system up the last year, restarts are on daily basis here. Sometimes even several on one day. Still never had an issue…

I’m not sure if you are aware but the connection from HA to Nabu Casa is separate from whether the remote connection to your own HA thru Nabu Casa is turned on.

I had this problem temporarily and tracked it down to a networking issue. As an interim solution, I created an automation to reconnect to Nabu Casa after reboot.

alias: Nabu Casa connect at restart
description: ''
trigger:
  - event: start
    platform: homeassistant
condition: []
action:
  - data: {}
    service: cloud.remote_connect

1 Like

Hmmm that looks promising - and testable.

Other solution could be to run your own VPN and connect through that. And ditch NC. I use the wire guard addon and it is rock solid.

VPNs are blocked by my employer’s network. And connecting to a VPN every time I want to view home assistant is a bit of a chore.

NC has been working 100% reliably for me since switching from DuckDNS.

The only complaint I have is that it is a little slower to load the first time as the servers are in another country.

Too bad VPN’s are blocked. Though have they blocked oddly high port ranges too? Wire guard works also on manually chosen ports. And on my phone and my wife’s it’s always on. So no hassle of connecting first.

I would have expected from a paid service like NC that they would have at least make use of a CDN.

So the error from this post could easily be a glitch in NC way of connecting. Because if you always connect locally you don’t get the error ever.

You might be confused. Tom is saying that he wouldn’t be able to reach HA from his work location through a VPN.
NC is not using a VPN.

Not really sure what you mean by that, but NC is not “delivering content”. It’s acting as a proxy, here…

Ok, so the terminology is wrong. But what I mean is that the proxy servers are scattered around the world and delivering their service from the closest around.

Your other remark about VPN’s I don’t get. Tom literally said they are blocked.

But the bottom line about the topic at hand is that it might be something related to NC.

Not sure what they use as IaaS (assuming they don’t handle their infrastructure themselves, here).
If they use AWS or similar, they could offer the choice of region, but that would increase their costs and thus the end-user price…

From the initial loading times they definitely dont have a proxy in Australia.

It’s not that bad once the cache has loaded once though.

A whois on your NC IP might tell what they use as infra. It’s very likely in the US, though.

Singapore.

So they are not only in the US.

1 Like