FTP server on motioneye addon settings - not connecting

Hi all,

I have a small memory card attached to my asus router usb and set up as an ftp/samba share on the network.

I was hoping to add the ftp server location to my motioneye upload settings to access them easily but cannot get it to connect at all.
I can access the storage from my browser and file explorer.
Also turned on the anonymous log in also just to test. Still won’t connect.

Tried with and without the prefix ftp://
port 21? Tried some other ports.

Any suggestions would be welcome. Thanks!

Anyone? Just me by the looks of it :frowning:

I’ve sent a note to github see what the owner thinks

Have you tried it without the location (can you access the / directory)?

Other than that, I’d check the FTP server settings … Connecting from the browser (generally port 80) and explorer doesn’t necessarily speak to the FTP server settings being correct.

I’ll give that a go.
Ispy agent dvr records to the ftp storage just fine though.
Folder location as /sda3/Office


Unfortunately the location field is mandatory. Still struggling


  File "/usr/lib/python2.7/site-packages/motioneye/uploadservices.py", line 854, in test_access
    conn = self._get_conn(create=True)
  File "/usr/lib/python2.7/site-packages/motioneye/uploadservices.py", line 911, in _get_conn
    self._conn.connect(self._server, port=self._port)
  File "/usr/lib/python2.7/ftplib.py", line 135, in connect
    self.sock = socket.create_connection((self.host, self.port), self.timeout)
  File "/usr/lib/python2.7/socket.py", line 557, in create_connection
    for res in getaddrinfo(host, port, 0, SOCK_STREAM):
gaierror: [Errno -2] Name does not resolve

Now getting

error_perm: 550 Permission denied (restricted operation).

This is quite clear but not sure why yet

hmm does this look right in the debug mode:

DEBUG: ftp: creating connection to userlogin@
   ERROR: ftp: [Errno -2] Name does not resolve

Yeah that does appear to be a configuration issue on the server side. Is the username “userlogin”? Are you certain it’s configured to listen on port 21 (which is indeed the standard port)? Are you able to test/connect with a different FTP client?

no I changed the username just as an example here.

Well on ispy agent dvr on my windows 10 it uses port 21 and with the same credentials and uploads fine.