Fully Kiosk Browser, Old Fire Tablets and Custom Cards

I’m sure this has been mentioned many times before and I have found mentions of the problem and solutions over 3 years ago, but things have changed since then.

TLDR; How can I get custom cards such as mini-media-player to load in Fully Kiosk Browser on older Kindle Fire Tablets when the custom cards were installed with HACS.

To expand on the TLDR above, I have a few Fire 7" tablets from 2017 that load the standard cards in Lovelace without issue but any custom cards don’t load. including the following:

  • mini-media-player
  • bar-card
  • home-feed-card
  • web-rtc-camera

Searching the forums returns a few similar questions and answers from 3+ years ago but the solution appears to be to amend custom cards in configuration.yaml to change the type to js like in the before and after below
before:

lovelace:
  resources:
    - url: /local/mini-media-player-bundle.js?v=1.16.5
      type: module

after:

lovelace:
  resources:
    - url: /local/mini-media-player-bundle.js?v=1.16.5
      type: js

However, my custom cards were installed using HACS and not manually added, like in the example above. How would I update this when installing via HACS or is this not possible?

I have 3 Fire tablets collecting dust and would be good to make use of them without installing Lineage or rooting in some other way. Another alternative would be to use simpler standard cards in the Dashboards on the tablets I guess.

I’ve no problem with any custom cards.

This is a fire tablet running the current Fire apk for Fully. Note: custom: button-card and bar card are both here and quite a few others. Didn’t have to do anything special except load the card in HACS…

@NathanCu How old is the Fire tablet you are running it on. I had seen several reports that the Webview it was using was not up to date enough. Although newer Fire tablets appeared to be OK.

To be honest the tablets did update when I turned them, they hadn’t been on in a long time.

Update: My Fire Tablets are running Fire OS 5.7.0.0, FKB 1.49.1 and when FKB starts it warns of an “Outdated version of Android Webview curr ver 59”

Did you get a solution? I have the same issue

For others who come across this: I was able to get it all working smoothly with an updated WebView. I downloaded it from https://amazon-system-webview.en.uptodown.com/android/download/101847171. (Found through XDA developer forums.)

1 Like

Thanks man! On the last update the fire hd won’t load HA. With the update is working!

Thank you @Valorum this worked for me, finally I can make use of done of these old Fire Tablets I have hanging around.

Worked for me as well. Thanks!

For others who come across this: I was able to get it all working smoothly with an updated WebView. I downloaded it from https://amazon-system-webview.en.uptodown.com/android/download/101847171 . (Found through XDA developer forums.)

How Do you know this file is legit?

Also works for me to fix a problem displaying a custom ha-floorplan dashboard using Fully Kiosk on an Amazon Fire 10.
The dashboard showed up fine every where (including Silk browser on the Fire 10) except in Fully Kiosk and HA companion app on the Fire 10.

For the ones like me that are experiencing this issue on a tablet other than Amazon’s, I got to update my webview using this tutorial. It says to search for “android system webview” (normal or beta) on the Play Store and install it. For me, I have a Galaxy Tab 8 running LineageOS. Just installed it and my dashboard came back to life.

I had to share this somehow because it took me ages to find a solution for this.